summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-06-12 22:06:09 +0300
committerTor Lillqvist <tml@iki.fi>2013-06-12 22:20:04 +0300
commit98910950890141c6236fb3c0e9914b20b0557b02 (patch)
tree685b0487698464e6b255307d73124cdbdf5d7873 /configure.ac
parentf7d373d18f965b36f310d44044bdba6476f6eb03 (diff)
Use xcode-select -print-path instead of hardcoding /Applications/Xcode.app
Change-Id: Ie576ba4497efac689a81c67474c61ec91c0a810b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 866022250375..bdca5c3fe4dd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2399,6 +2399,8 @@ dnl Check / find MacOSX SDK and compiler, version checks
dnl ===================================================================
if test "$_os" = "Darwin"; then
+ xcode_developer=`xcoce-select -print-path`
+
if test "$enable_64_bit" = "" -o "$enable_64_bit" = "no"; then
bitness=-m32
else
@@ -2684,7 +2686,7 @@ if test $_os = iOS; then
pref_sdk_ver=6.1
for I in 6.1 6.0; do
- t=/Applications/Xcode.app/Contents/Developer/Platforms/$platform.platform/Developer/SDKs/$platform$I.sdk
+ t=$xcode_developer/Platforms/$platform.platform/Developer/SDKs/$platform$I.sdk
if test -d $t; then
sysroot=$t
break
@@ -2692,13 +2694,13 @@ if test $_os = iOS; then
done
if test -z "$sysroot"; then
- AC_MSG_ERROR([Could not find iOS SDK, expected something like /Applications/Xcode.app/Contents/Developer/Platforms/$platform.platform/Developer/SDKs/${platform}${pref_sdk_ver}])
+ AC_MSG_ERROR([Could not find iOS SDK, expected something like $xcode_developer/Platforms/$platform.platform/Developer/SDKs/${platform}${pref_sdk_ver}])
fi
AC_MSG_RESULT($sysroot)
- CXX="/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch $arch -isysroot $sysroot $versionmin"
- CC="/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch $arch -isysroot $sysroot $versionmin"
+ CXX="$xcode_developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch $arch -isysroot $sysroot $versionmin"
+ CC="$xcode_developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -arch $arch -isysroot $sysroot $versionmin"
fi
AC_MSG_CHECKING([whether to treat the installation as read-only])