summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2013-11-20 15:37:34 +0100
committerMichael Stahl <mstahl@redhat.com>2013-11-20 15:39:40 +0100
commit776f48eb97a99e077824741ad300fed27e4edd14 (patch)
treecd9502c08a481e376d9a2418a2ce23d9ce814df5 /configure.ac
parentc24eba06580cbeb1e6a6d0a4d3fe2cfa22abd8a7 (diff)
Revert "fdo#67060 do not package RPM-only install script to DEB packs"
Put back the definition of WITH_RPM: otherwise a build --with-pkgformat=archive fails since the scripts/install is not built. Leave in the change to installer that should fix the original DEB bug. This reverts commit 4f995b395ea347469ca9c7681d2f01f63e966d96. Change-Id: I0cf4ba003237c66dfb7a0677d6a32a69f8203c6b
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c136c055e89..14fdbfd75e84 100755
--- a/configure.ac
+++ b/configure.ac
@@ -7347,6 +7347,7 @@ if test "$enable_epm" = "yes"; then
elif "$RPM" --help 2>&1 | $EGREP buildroot >/dev/null; then
RPM_PATH=`which $RPM`
AC_MSG_RESULT([$RPM_PATH])
+ SCPDEFS="$SCPDEFS -DWITH_RPM"
else
AC_MSG_ERROR([cannot build packages. Try installing rpmbuild.])
fi