summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBryan Quigley <gquigs@gmail.com>2014-08-04 17:31:23 -0400
committerStephan Bergmann <sbergman@redhat.com>2014-09-09 15:20:35 +0200
commit496bc3cd6c037360632c33471c4622a095cdcadd (patch)
tree694253c3f03821765ec9fa3636e4255b3c4ea210 /configure.ac
parent1d62f6a24f6160c33ad5c96f39b2ab3c918f0625 (diff)
fdo#45071 Remove Libreoffice browser plugin
This removes ENABLE_NPAPI_INTO_BROWSER while it should keep ENABLE_NPAPI_FROM_BROWSER (embed flash in LO) intact. Signed-off-by: Stephan Bergmann <sbergman@redhat.com> Conflicts: extensions/source/nsplugin/source/npshell.cxx Change-Id: I80a9159a75653c74423d8fdc7c188568d3188e04
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 1 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 2fc22bc2c436..b7d2fe035cbb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1889,7 +1889,6 @@ AC_ARG_WITH(system-liblangtag,
AC_ARG_WITH(system-npapi-headers,
AS_HELP_STRING([--with-system-npapi-headers],
[Use NPAPI headers provided by system instead of bundled ones. Used in
- extensions/source/nsplugin (ENABLE_NPAPI_INTO_BROWSER=TRUE) and
extensions/source/plugin (ENABLE_NPAPI_FROM_BROWSER=TRUE)]),,
[with_system_npapi_headers="$with_system_headers"]
)
@@ -8964,8 +8963,7 @@ if test "$with_system_npapi_headers" = "yes"; then
NPAPI_HEADERS_CFLAGS=$(printf '%s' "$NPAPI_HEADERS_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
else
AC_MSG_RESULT([internal])
- dnl ...but will not be built/used unless ENABLE_NPAPI_FROM_BROWSER or
- dnl ENABLE_NPAPI_INTO_BROWSER is TRUE
+ dnl ...but will not be built/used unless ENABLE_NPAPI_FROM_BROWSER
SYSTEM_NPAPI_HEADERS=
fi
AC_SUBST(NPAPI_HEADERS_CFLAGS)
@@ -9205,21 +9203,6 @@ else
fi
AC_SUBST(ENABLE_NPAPI_FROM_BROWSER)
-dnl ===================================================================
-dnl Check for NPAPI interface to plug LibreOffice into browser windows
-dnl ===================================================================
-AC_MSG_CHECKING([whether to plug LibreOffice into browser windows])
-if test "$enable_mpl_subset" != yes -a \( "$_os" = WINNT -o "$_os" != Android -a "$_os" != Darwin -a "$_os" != iOS -a \
- "$enable_headless" != yes -a "$enable_gtk" != no \)
-then
- AC_MSG_RESULT([yes])
- ENABLE_NPAPI_INTO_BROWSER=TRUE
-else
- AC_MSG_RESULT([no])
- ENABLE_NPAPI_INTO_BROWSER=
-fi
-AC_SUBST(ENABLE_NPAPI_INTO_BROWSER)
-
AC_MSG_CHECKING([whether to use X11])
dnl ***************************************
dnl testing for X libraries and includes...