summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Tardon <dtardon@redhat.com>2013-11-16 11:20:27 +0100
committerDavid Tardon <dtardon@redhat.com>2013-11-16 11:20:27 +0100
commit40b2a899d5bcba98be371a93c635d04d36ff2c2b (patch)
treec6746825c8163b9d18c9f30aa296db04ad326d3a /configure.ac
parentb1ab93642d770e35a3bf4ba4b41c17dd27382eb5 (diff)
fail if avahi is not found
If I configure with --enable-avahi, presumably I want the code to be built with avahi support...
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 0ef3f5345b04..fbac8efb81bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11700,11 +11700,9 @@ dnl Test whether to use avahi
dnl ===================================================================
if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_avahi" = "yes"; then
PKG_CHECK_MODULES([AVAHI], [avahi-client >= 0.6.10],
- [ENABLE_AVAHI="TRUE"], [ENABLE_AVAHI=""])
- if test "$ENABLE_AVAHI" = "TRUE"; then
- AC_DEFINE(HAVE_FEATURE_AVAHI)
- AVAHI_CFLAGS=$(printf '%s' "$AVAHI_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
- fi
+ [ENABLE_AVAHI="TRUE"])
+ AC_DEFINE(HAVE_FEATURE_AVAHI)
+ AVAHI_CFLAGS=$(printf '%s' "$AVAHI_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
fi
AC_SUBST(ENABLE_AVAHI)