summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-06-13 11:11:41 +0300
committerTor Lillqvist <tml@iki.fi>2013-06-13 11:15:06 +0300
commit348c7ca4b7676b10864bade1d5a16761b7927418 (patch)
tree1f640f66b4f48f68268cc90a6ffc565c800f8bcf /configure.ac
parent9760621b5c93edb829478c284e4b61537824e702 (diff)
Simplify EPM tests for OS X
We always should use the internal epm anyway on OS X, so no need to look for PackageMaker.app in /Developer which doesn't even exist any more. Change-Id: I943f34e14e9ce0c3bec5bd7b86612a62e5b9e83d
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 3 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index bdca5c3fe4dd..7c7575e9a9ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6785,7 +6785,9 @@ AC_MSG_CHECKING([whether to enable EPM for packing])
if test "$enable_epm" = "yes"; then
AC_MSG_RESULT([yes])
if test "$_os" != "WINNT"; then
- if test -n "$with_epm"; then
+ if test $_os = Darwin; then
+ EPM=internal
+ elif test -n "$with_epm"; then
EPM=$with_epm
else
AC_PATH_PROG(EPM, epm, no)
@@ -6806,17 +6808,6 @@ if test "$enable_epm" = "yes"; then
if test "`echo $EPM_VERSION | cut -d'.' -f1`" -gt "3" || \
test "`echo $EPM_VERSION | cut -d'.' -f1`" -eq "3" -a "`echo $EPM_VERSION | cut -d'.' -f2`" -ge "7"; then
AC_MSG_RESULT([OK, >= 3.7])
- if test "$_os" = "Darwin"; then
- AC_MSG_CHECKING([which PackageMaker EPM thinks to use])
- _pm=`strings $EPM | grep PackageMaker | cut -d" " -f1`
- if test "$_pm" = "/Developer/Applications/PackageMaker.app/Contents/MacOS/PackageMaker"; then
- AC_MSG_ERROR([$_pm; PackageMaker expected in wrong path. Either patch your epm with the right path (/Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker) or use internal patched epm (--with-epm=internal)])
- elif test "$_pm" = "/Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker"; then
- AC_MSG_RESULT([$_pm, ok])
- else # we never should get here, but go safe
- AC_MSG_ERROR([$_pm; PackageMaker expected in unknown path. Either patch your epm with the right path (/Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker) or use internal patched epm (--with-epm=internal)])
- fi
- fi
else
AC_MSG_RESULT([too old. epm >= 3.7 is required.])
echo "EPM will be built."