summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej J.R. Hunt <andrzej@ahunt.org>2013-11-06 19:41:30 +0000
committerAndrzej J.R. Hunt <andrzej@ahunt.org>2013-11-06 19:41:30 +0000
commit31fd531b2757269dde108b362752f7949615736a (patch)
tree373e19d27475709d26c8f1222a2604b6a5225662 /configure.ac
parent0351eaf42f4ebda8564f0f7cdf32706dfff735f6 (diff)
Revert "Make libatomic_ops buildable and enable on non-X86."
(Pushed from wrong branch -- incomplete/broken.) This reverts commit 0351eaf42f4ebda8564f0f7cdf32706dfff735f6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 8 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 13751e9086ec..b73df30d377f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8511,22 +8511,14 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
elif test "$cross_compiling" = "yes"; then
AC_MSG_RESULT([none])
else
- dnl We need libatomic-ops for any non X86/X64 system
- if test "$CPU" != I -a "$CPU" != X; then
- dnl ===================================================================
- dnl Check for system libatomic-ops
- dnl ===================================================================
- libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
- if test "$with_system_libatomic_ops" = "yes"; then
- SYSTEM_LIBATOMIC_OPS=YES
- AC_CHECK_HEADERS(atomic_ops.h, [],
- [AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
- else
- SYSTEM_LIBATOMIC_OPS=NO
- LIBATOMIC_OPS_CFLAGS="-I${WORKDIR}/UnpackedTarball/libatomic_ops/include"
- LIBATOMIC_OPS_LIBS="-latomic_ops"
- BUILD_TYPE="$BUILD_TYPE LIBATOMIC_OPS"
- fi
+ dnl ===================================================================
+ dnl Check for system libatomic-ops
+ dnl ===================================================================
+ libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
+ if test "$with_system_libatomic_ops" = "yes"; then
+ SYSTEM_LIBATOMIC_OPS=YES
+ AC_CHECK_HEADERS(atomic_ops.h, [],
+ [AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
fi
AC_MSG_RESULT([internal])
@@ -8540,9 +8532,6 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
fi
AC_SUBST(ENABLE_FIREBIRD_SDBC)
-AC_SUBST(SYSTEM_LIBATOMIC_OPS)
-AC_SUBST(LIBATOMIC_OPS_CFLAGS)
-AC_SUBST(LIBATOMIC_OPS_LIBS)
AC_SUBST(SYSTEM_FIREBIRD)
AC_SUBST(FIREBIRD_CFLAGS)
AC_SUBST(FIREBIRD_LIBS)