summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej J.R. Hunt <andrzej@ahunt.org>2013-10-06 14:45:55 +0100
committerBjörn Michaelsen <bjoern.michaelsen@canonical.com>2013-11-20 14:41:51 -0600
commit24b4610e10a539609a6679b598de7dc7957791c0 (patch)
treeda941b69e5c4af5e7f3153e2d6b7e0b3e00e83a8 /configure.ac
parente587d0c98a5cc819df8c811e7c7347b87a3093ab (diff)
Separate Impress Remote from Android build.
Previously the Impress Remote app could only be built within gbuild when building the entirety of LO for Android, it can now be enabled separately to be built within any LO build. (Note that the app could still be built separately without doing a full Android build of LO by using the android build tools and/or IDE.) Conflicts: config_host.mk.in Change-Id: I21d4389082a1492a3c9029d630f3fff97d9ba99a Reviewed-on: https://gerrit.libreoffice.org/6146 Reviewed-by: Björn Michaelsen <bjoern.michaelsen@canonical.com> Tested-by: Björn Michaelsen <bjoern.michaelsen@canonical.com>
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac40
1 files changed, 30 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 14fdbfd75e84..b209742449f2 100755
--- a/configure.ac
+++ b/configure.ac
@@ -210,7 +210,8 @@ AC_ARG_WITH(android-ndk-toolchain-version,
AC_ARG_WITH(android-sdk,
AS_HELP_STRING([--with-android-sdk],
- [Specify location of the Android SDK. Mandatory when building for Android.]),
+ [Specify location of the Android SDK. Mandatory when building for Android,
+ or when building the Impress Remote Android app.]),
,)
ANDROID_NDK_HOME=
@@ -660,19 +661,11 @@ linux-android*)
AC_MSG_ERROR([the --with-android-ndk-toolchain-version option is mandatory])
fi
- if test -z "$with_android_sdk"; then
- AC_MSG_ERROR([the --with-android-sdk option is mandatory])
- fi
-
# Verify that the NDK and SDK options are proper
if test ! -f "$ANDROID_NDK_HOME/platforms/android-9/arch-arm/usr/lib/libc.a"; then
AC_MSG_ERROR([the --with-android-ndk option does not point to an Android NDK])
fi
- if test ! -d "$ANDROID_SDK_HOME/platforms"; then
- AC_MSG_ERROR([the --with-android-sdk option does not point to an Android SDK])
- fi
-
AC_DEFINE(HAVE_FT_FACE_GETCHARVARIANTINDEX)
BUILD_TYPE="$BUILD_TYPE FONTCONFIG FREETYPE"
;;
@@ -682,6 +675,16 @@ linux-android*)
;;
esac
+if echo "$host_os" | grep -q linux-android || test "$enable_sdremote_android" = "yes"; then
+ if test -z "$with_android_sdk"; then
+ AC_MSG_ERROR([the --with-android-sdk option is mandatory])
+ fi
+
+ if test ! -d "$ANDROID_SDK_HOME/platforms"; then
+ AC_MSG_ERROR([the --with-android-sdk option does not point to an Android SDK])
+ fi
+fi
+
if test "$_os" = "AIX"; then
AC_PATH_PROG(GAWK, gawk)
if test -z "$GAWK"; then
@@ -997,7 +1000,7 @@ AC_ARG_ENABLE(packagekit,
AC_ARG_ENABLE(sdremote,
AS_HELP_STRING([--disable-sdremote],
- [Determines whether to enable Impress remote control.]),
+ [Determines whether to enable Impress remote control (i.e. the server component).]),
,enable_sdremote=yes)
AC_ARG_ENABLE(sdremote-bluetooth,
@@ -1005,6 +1008,12 @@ AC_ARG_ENABLE(sdremote-bluetooth,
[Determines whether to build sdremote with bluetooth support.
Requires dbus on Linux.]))
+AC_ARG_ENABLE(sdremote-android,
+ AS_HELP_STRING([--enable-sdremote-android],
+ [Determines whether to build the Impress Remote Android app -- requires
+ a correctly configured android sdk. Automatically enabled if ]),
+,enable_sdremote_android=no)
+
AC_ARG_ENABLE(gconf,
AS_HELP_STRING([--disable-gconf],
[Determines whether to use the GConf support.]),
@@ -10116,6 +10125,17 @@ AC_SUBST(ENABLE_SDREMOTE)
AC_SUBST(ENABLE_SDREMOTE_BLUETOOTH)
AC_SUBST(SYSTEM_BLUEZ)
+AC_MSG_CHECKING([whether to enable Impress remote control android app])
+if echo "$host_os" | grep -q linux-android || test "$enable_sdremote_android" = "yes"; then
+ AC_MSG_RESULT([yes])
+ ENABLE_SDREMOTE_ANDROID=TRUE
+ AC_MSG_CHECKING([whether to enable Bluetooth support in Impress remote control])
+else
+ ENABLE_SDREMOTE=
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_SDREMOTE_ANDROID)
+
dnl ===================================================================
dnl Check whether the gtk 2.0 libraries are available.
dnl ===================================================================