summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-09-29 17:35:57 +0200
committerMichael Stahl <mstahl@redhat.com>2014-10-01 23:16:17 +0200
commit13cb02ce1046779864109646a105c09c2e27249a (patch)
treeb04062413ca85cb5f8ac943bdd8ab801851388c0 /configure.ac
parentd08110c0be9e5290240082d899d45938730684eb (diff)
configure: limit javac VM usage
Similarly, restrict javac to 128M, which is enough for me with JDK 1.7 on Linux x86_64. Change-Id: I5b1e3435026b8b69bf7afe8b5236c3dc09857f49
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af2bda898352..f4f6ceb6786c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6715,6 +6715,8 @@ you must use the "--with-jdk-home" configure option explicitly])
# set to limit VM usage for JunitTests
JAVAIFLAGS=-Xmx64M
+ # set to limit VM usage for javac
+ JAVAFLAGS=-J-Xmx128M
fi
else
AC_MSG_ERROR([Java not found. You need at least jdk-1.5, or gcj-4])
@@ -7033,6 +7035,7 @@ AC_SUBST(JAVACOMPILER)
AC_SUBST(JAVADOC)
AC_SUBST(JAVAINTERPRETER)
AC_SUBST(JAVAIFLAGS)
+AC_SUBST(JAVAFLAGS)
AC_SUBST(JAVA_CLASSPATH_NOT_SET)
AC_SUBST(JAVA_HOME)
AC_SUBST(JAVA_SOURCE_VER)