summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@iki.fi>2013-06-26 13:41:36 +0300
committerTor Lillqvist <tml@iki.fi>2013-06-26 14:19:41 +0300
commit1365a4d281f969e8cd3833422b2d771621d40245 (patch)
tree6e263b60d694f59239f54512a74762cca35feec6 /configure.ac
parent673205080eee4c6ce20375c9a28b5dc34d3c5475 (diff)
Need to use the right libtool on OS X
Change-Id: I37b2a892143892740674ce9882ed61ea88eda894
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cfe202358e21..1e1108f70093 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2591,6 +2591,7 @@ if test $_os = Darwin; then
fi
# If no CC and CXX environment vars, try to guess where the compiler is
+ LIBTOOL=libtool
if test -z "$save_CC"; then
AC_MSG_CHECKING([what compiler to use])
case $with_macosx_sdk in
@@ -2604,6 +2605,7 @@ if test $_os = Darwin; then
CC="gcc-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
CXX="g++-4.2 $bitness -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
fi
+ LIBTOOL=libtool
;;
10.7|10.8|10.9)
if test "$enable_libc__" = yes -a "$with_macosx_version_min_required" != 10.6; then
@@ -2619,6 +2621,7 @@ if test $_os = Darwin; then
CXX="`xcrun -find clang++` $bitness $lto $stdlib -mmacosx-version-min=$with_macosx_version_min_required -isysroot $MACOSX_SDK_PATH"
XCRUN=xcrun
AR=`xcrun -find ar`
+ LIBTOOL=`xcrun -find libtool`
RANLIB=`xcrun -find ranlib`
;;
esac
@@ -2715,6 +2718,7 @@ AC_SUBST(MACOSX_DEPLOYMENT_TARGET)
AC_SUBST(MAC_OS_X_VERSION_MIN_REQUIRED)
AC_SUBST(MAC_OS_X_VERSION_MAX_ALLOWED)
AC_SUBST(XCRUN)
+AC_SUBST(LIBTOOL) # Note that the OS X libtool command is unrelated to GNU libtool
AC_SUBST(MACOSX_CODESIGNING_IDENTITY)
AC_SUBST(ENABLE_MACOSX_SANDBOX)
AC_SUBST(MACOSX_BUNDLE_IDENTIFIER)
@@ -2761,6 +2765,7 @@ if test $_os = iOS; then
CXX="`xcrun -find clang++` -arch $arch -isysroot $sysroot $lto $versionmin"
XCRUN=xcrun
AR=`xcrun -find ar`
+ LIBTOOL=`xcrun -find libtool`
RANLIB=`xcrun -find ranlib`
fi