summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNorbert Thiebaud <nthiebaud@gmail.com>2013-11-15 10:43:20 -0600
committerBjörn Michaelsen <bjoern.michaelsen@canonical.com>2013-11-21 02:06:05 -0600
commit09e2349c51cd9a8e5d7544e07266a5ff681ef328 (patch)
treec54eed6876bf353e12613a45a145ef3f054c2023 /configure.ac
parent3e8fe4d8e19be2ccd8f5bb898530e2f615a90321 (diff)
Save downloaded tarballs under external/tarballs/
The choice of src/ as a place to save those tarballs was unfortunate, since it is used everywhere else for own source code. After moving all external modules to external/, it makes sense to put the tarballs there too and, while at it, use a more appropriate name. If src exist as a directory, we move it to external/tarballs and leave a link behind for backward compat for people switching from after to before the change in the git repo. Change-Id: I045c4470945f5fadf7760855833ef58e6594ec80 Reviewed-on: https://gerrit.libreoffice.org/6597 Reviewed-by: Björn Michaelsen <bjoern.michaelsen@canonical.com> Tested-by: Björn Michaelsen <bjoern.michaelsen@canonical.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fd47321e83c2..dc7be27a5012 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4669,7 +4669,11 @@ AC_SUBST([SYSTEM_FONTCONFIG])
dnl whether to find & fetch external tarballs?
dnl ===================================================================
if test -z "$TARFILE_LOCATION"; then
- TARFILE_LOCATION="$SRC_ROOT/src"
+ if test -d "$SRC_ROOT/src" ; then
+ mv "$SRC_ROOT/src" "$SRC_ROOT/external/tarballs"
+ ln -s "$SRC_ROOT/external/tarballs" "$SRC_ROOT/src"
+ fi
+ TARFILE_LOCATION="$SRC_ROOT/external/tarballs"
fi
AC_SUBST(TARFILE_LOCATION)