summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndrzej J.R. Hunt <andrzej@ahunt.org>2013-09-05 16:27:50 +0100
committerAndrzej J.R. Hunt <andrzej@ahunt.org>2013-11-06 13:20:34 -0600
commit0351eaf42f4ebda8564f0f7cdf32706dfff735f6 (patch)
tree2d8a2cfc6f7b301c1fb179632ca627201595d10e /configure.ac
parent7813bd3113beb2b2860f9eb213c5c67ef54f5bf0 (diff)
Make libatomic_ops buildable and enable on non-X86.
Change-Id: I9423672b03caa4d500d44155bc47d4a8fa10c3cb Reviewed-on: https://gerrit.libreoffice.org/5812 Reviewed-by: Andrzej J.R. Hunt <andrzej@ahunt.org> Tested-by: Andrzej J.R. Hunt <andrzej@ahunt.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 19 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index b73df30d377f..13751e9086ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8511,14 +8511,22 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
elif test "$cross_compiling" = "yes"; then
AC_MSG_RESULT([none])
else
- dnl ===================================================================
- dnl Check for system libatomic-ops
- dnl ===================================================================
- libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
- if test "$with_system_libatomic_ops" = "yes"; then
- SYSTEM_LIBATOMIC_OPS=YES
- AC_CHECK_HEADERS(atomic_ops.h, [],
- [AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
+ dnl We need libatomic-ops for any non X86/X64 system
+ if test "$CPU" != I -a "$CPU" != X; then
+ dnl ===================================================================
+ dnl Check for system libatomic-ops
+ dnl ===================================================================
+ libo_CHECK_SYSTEM_MODULE([libatomic_ops],[ATOMIC_OPS],[atomic_ops >= 0.7.2])
+ if test "$with_system_libatomic_ops" = "yes"; then
+ SYSTEM_LIBATOMIC_OPS=YES
+ AC_CHECK_HEADERS(atomic_ops.h, [],
+ [AC_MSG_ERROR(atomic_ops.h not found. install libatomic-ops)], [])
+ else
+ SYSTEM_LIBATOMIC_OPS=NO
+ LIBATOMIC_OPS_CFLAGS="-I${WORKDIR}/UnpackedTarball/libatomic_ops/include"
+ LIBATOMIC_OPS_LIBS="-latomic_ops"
+ BUILD_TYPE="$BUILD_TYPE LIBATOMIC_OPS"
+ fi
fi
AC_MSG_RESULT([internal])
@@ -8532,6 +8540,9 @@ if test "x$enable_firebird_sdbc" = "xyes"; then
fi
AC_SUBST(ENABLE_FIREBIRD_SDBC)
+AC_SUBST(SYSTEM_LIBATOMIC_OPS)
+AC_SUBST(LIBATOMIC_OPS_CFLAGS)
+AC_SUBST(LIBATOMIC_OPS_LIBS)
AC_SUBST(SYSTEM_FIREBIRD)
AC_SUBST(FIREBIRD_CFLAGS)
AC_SUBST(FIREBIRD_LIBS)