summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZolnai Tamás <tamas.zolnai@collabora.com>2014-04-19 18:04:24 +0200
committerZolnai Tamás <tamas.zolnai@collabora.com>2014-04-19 18:10:14 +0200
commitf333d58e73ac39b48ae655fd9e123a4ca77f1562 (patch)
tree4b3dbe66e761a2316eaa665ee0110d17e6083ee2 /configure.ac
parentcda58f93811a932a4cd28cedfd6606a01d03e89d (diff)
Introduce a new building flag to enable/disable gltf support
Enable it by defautl excepting android and ios. Change-Id: I7798661ad7e470ad1eb91060ec21ba1de3979a4b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 49ca49aa90c1..63a60da505c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1366,6 +1366,10 @@ AC_ARG_ENABLE(library-bin-tar,
for the next time.]),
)
+AC_ARG_ENABLE(gltf,
+ AS_HELP_STRING([--disable-gltf],
+ [Determines whether to build libraries related to glTF 3D model rendering.]))
+
dnl ===================================================================
dnl Optional Packages (--with/without-)
dnl ===================================================================
@@ -10364,7 +10368,7 @@ dnl ===================================================================
ENABLE_GLTF=
AC_MSG_CHECKING([whether to enable glTF support])
-if test "$enable_opengl" = "yes"; then
+if test $_os != iOS -a $_os != Android -a "x$enable_gltf" != "xno"; then
ENABLE_GLTF=TRUE
AC_MSG_RESULT([yes])
BUILD_TYPE="$BUILD_TYPE LIBGLTF"