summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorZolnai Tamás <tamas.zolnai@collabora.com>2014-04-18 10:10:39 +0200
committerZolnai Tamás <tamas.zolnai@collabora.com>2014-04-18 11:19:26 +0200
commitb6cbb15026e2df1e985f19c5bb723f64a26f2658 (patch)
tree2e8aa9e3d15b78dbc1b08b12b0f94e2292bd8129 /configure.ac
parentec95e6a17c591bff6c0582c304c1beeb1efe141f (diff)
Freetype is needed by libgltf on all platforms
Change-Id: I042cbc5f4cabfa7ec387594189e2f86be6ec7fbf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3a294ca21476..50c811706067 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10359,6 +10359,23 @@ fi
AC_SUBST(ENABLE_OPENCL)
+dnl ===================================================================
+dnl Check whether to enable glTF support
+dnl ===================================================================
+
+ENABLE_GLTF=
+AC_MSG_CHECKING([whether to enable glTF support])
+if test "$enable_opengl" = "yes"; then
+ ENABLE_GLTF=TRUE
+ AC_MSG_RESULT([yes])
+ if test "$test_freetype" = "no"; then
+ BUILD_TYPE="$BUILD_TYPE FREETYPE"
+ fi
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_GLTF)
+
# pdf import?
AC_MSG_CHECKING([whether to build the PDF import feature])
ENABLE_PDFIMPORT=