summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2014-04-17 23:51:04 +0300
committerTor Lillqvist <tml@collabora.com>2014-04-18 00:04:15 +0300
commit629cc605a45e75d6896b524eada2354c1d4d33a8 (patch)
treea9bea5727019feaf545706e5694692c4742c1085 /configure.ac
parent558aa44672fe3565dfe1eab82c8766f2f499ee0d (diff)
Intermediate commit of hacking on --disable-database-connectivity
Add HAVE_FEATURE_DBCONNECTIVITY to <config_features.h> instead of using (or not, more likely) -DDISABLE_DBCONNECTIVITY. The plan is still that database connectivity would be disabled always for the non-desktop platforms, and otherwise disabling it would be a configure option. But, still lots to do; the TiledLibreOffice iOS test app gets tons of undefineds when linking if I actually try to disable the database connectivity. Change-Id: If1e4b55faa1514cd55dec5fc5487a30d689739ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 7 insertions, 21 deletions
diff --git a/configure.ac b/configure.ac
index 4e83ed6b5d92..3a294ca21476 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2359,35 +2359,21 @@ else
SCPDEFS="$SCPDEFS -DDISABLE_AVMEDIA"
fi
-dnl Decide whether to build database connectivity stuff (including
-dnl Base) or not. We probably don't want to on non-desktop OSes.
+# Decide whether to build database connectivity stuff (including
+# Base) or not. We probably don't want to on non-desktop OSes.
if test -z "$enable_database_connectivity"; then
- # Do enable database connectivity for Android for now as otherwise
- # we presumably will get linking errors... We are not as far in
- # the work for iOS, so we might as well disable it for iOS already.
-
- # And actually, do enable it for iOS, too. Let's get back to
- # figuring out what to do with this later, if ever.
-
- # (Note that with "enable", I mean "enable building the related
- # code". Very likely little of it will make any sense at run-time
- # on Android or iOS and won't even be shipped with/linked into any
- # app.)
-
- #if test $_os != iOS; then
+ # --disable-database-connectivity is unfinished work in progress
+ # and the iOS test app doesn't link if we actually try to use it.
+ # if test $_os != iOS -a $_os != Android; then
enable_database_connectivity=yes
- #fi
+ # fi
fi
-DISABLE_DBCONNECTIVITY=''
if test "$enable_database_connectivity" = yes; then
BUILD_TYPE="$BUILD_TYPE DBCONNECTIVITY"
-else
- DISABLE_DBCONNECTIVITY='TRUE'
- SCPDEFS="$SCPDEFS -DDISABLE_DBCONNECTIVITY"
+ AC_DEFINE(HAVE_FEATURE_DBCONNECTIVITY)
fi
-AC_SUBST(DISABLE_DBCONNECTIVITY)
if test -z "$enable_extensions"; then
# For iOS and Android disable extensions unless specifically overridden with --enable-extensions.