summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorJens-Heiner Rechtien <hr@openoffice.org>2007-11-01 13:44:12 +0000
committerJens-Heiner Rechtien <hr@openoffice.org>2007-11-01 13:44:12 +0000
commite327f1eb0f0849c4928931df8c748d8e3742f1af (patch)
tree3b12370ace9de4e6dc85838a051e05b148af8242 /config_office/configure.in
parentc3dda28dbcd758b78ac51ea2d5bddf2646186461 (diff)
INTEGRATION: CWS thbpp9_SRC680 (1.216.2.2.8); FILE MERGED
2007/10/17 13:54:09 thb 1.216.2.2.8.1: #i81224# Applied patch from rene
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in27
1 files changed, 16 insertions, 11 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index e2a4e5bb99c2..9d603b0a3720 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2007-10-25 16:00:29 $
+dnl * Date: $Date: 2007-11-01 14:44:12 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.223 $ )
+AC_REVISION( $Revision: 1.224 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -4092,15 +4092,20 @@ else
else
AGG_INCDIR="`echo $AGG_CFLAGS | $SED -e s/-I//`"
fi
- # we could have used pkg-config --modversion but 2.4's libagg.pc.in still contains 2.3 :/
- if $GREP -q "Version 2.4" `echo $AGG_INCDIR`/agg_basics.h; then
- AC_MSG_RESULT([2.4])
- AGG_VERSION=2400
- else
- AC_MSG_RESULT([2.3])
- AGG_VERSION=2300
- fi
- SYSTEM_AGG=YES
+ if $PKG_CONFIG --modversion libagg | grep -q 2.3 || \
+ $PKG_CONFIG --modversion libagg | grep -q 2.4; then
+ # 2.4's libagg.pc.in still contains 2.3 :/
+ if $GREP -q "Version 2.4" `echo $AGG_INCDIR`/agg_basics.h; then
+ AC_MSG_RESULT([2.4])
+ AGG_VERSION=2400
+ else
+ AC_MSG_RESULT([2.3])
+ AGG_VERSION=2300
+ fi
+ SYSTEM_AGG=YES
+ else
+ AC_MSG_ERROR([only agg 2.3 and 2.4 are supported])
+ fi
else
AC_MSG_RESULT([internal])
SYSTEM_AGG=NO