summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorVladimir Glazounov <vg@openoffice.org>2007-08-30 09:02:41 +0000
committerVladimir Glazounov <vg@openoffice.org>2007-08-30 09:02:41 +0000
commitc08cd218f5d8032b04935a790a53aa744f3bcf1f (patch)
tree384c5278a2ab47437fda637ef152dff1c1befdf0 /config_office/configure.in
parent1a30b497ce903e4ad02138dd0496689c0bb565a5 (diff)
INTEGRATION: CWS npower7 (1.201.2); FILE MERGED
2007/07/05 11:47:47 npower 1.201.2.2: RESYNC: (1.201-1.209); FILE MERGED 2007/05/03 11:09:38 npower 1.201.2.1: #i76844#
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in34
1 files changed, 19 insertions, 15 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index 6b4c3baf2446..d1fad62550fc 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2007-08-27 16:05:43 $
+dnl * Date: $Date: 2007-08-30 10:02:41 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.218 $ )
+AC_REVISION( $Revision: 1.219 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -41,20 +41,21 @@ AC_ARG_ENABLE(lockdown,
[ --enable-lockdown Enables the gconf integration work in OOo
],,)
AC_ARG_ENABLE(vba,
-[ --enable-vba Enables the vba compatibility feature
+[ --disable-vba disables the vba compatibility feature
],,)
AC_ARG_WITH(vba-package-format,
[ --with-vba-package-format specify package format for vba compatibility api.
- Default "builtin" means the api component and
+ Specifying "builtin" means the api component and
associated type library are part of the installation set.
- Specifying "extsn" creates an uno extension that is
+ Specifying "extn" creates an uno extension that is
part of the installation set ( located in the program
directory ) that MUST be optionly registered using
either the unopkg executeable or the extension manager
gui.
-
- Usage: --with-package-format="builtin" or
- --with-package-format="extsn"
+
+ Note: "extn" is the defualt.
+ Usage: --with-vba-package-format="builtin" or
+ --with-vba-package-format="extn"
],,)
AC_ARG_ENABLE(pch,
[ --enable-pch EXPERIMENTAL: Enables precompiled header support for C++.
@@ -1634,13 +1635,13 @@ fi
dnl ===================================================================
dnl Check if we are to enable vba macro interoperability feature
dnl ===================================================================
-AC_MSG_CHECKING([whether to enable vba feature])
-if test -n "$enable_vba" && test "$enable_vba" = "yes"; then
+AC_MSG_CHECKING([whether to disable vba feature])
+if test -n "$enable_vba" && test "$enable_vba" = "no"; then
AC_MSG_RESULT([yes])
- ENABLE_VBA=YES
-else
ENABLE_VBA=NO
+else
AC_MSG_RESULT([no])
+ ENABLE_VBA=YES
fi
AC_SUBST(ENABLE_VBA)
@@ -1659,11 +1660,14 @@ if test "$ENABLE_VBA" = "YES"; then
fi
else
- VBA_EXTENSION=NO
- AC_MSG_RESULT([build into installset])
+ VBA_EXTENSION=YES
+ AC_MSG_RESULT([defaulting to build as uno extension])
fi
- AC_SUBST(VBA_EXTENSION)
+else
+ VBA_EXTENSION=NO
fi
+AC_SUBST(VBA_EXTENSION)
+
dnl ===================================================================
dnl Check the whether vba need to be delivered as an uno package or part
dnl of the install