summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorJens-Heiner Rechtien <hr@openoffice.org>2007-08-02 13:58:57 +0000
committerJens-Heiner Rechtien <hr@openoffice.org>2007-08-02 13:58:57 +0000
commit9229ada813aa342e59701163d77e5202d39aefb0 (patch)
tree05dd8257b9da74f8bd5da789206bef9d20aa245e /config_office/configure.in
parent1b4f77be579c4e537d7b1090cbd8fdf3ac4d414b (diff)
INTEGRATION: CWS vcl81 (1.213.4); FILE MERGED
2007/07/30 13:46:18 rene 1.213.4.2: #i80096# no need for HEADLESS anymore 2007/07/24 12:36:22 pl 1.213.4.1: #i79953# use dbus to disable screen saver (thanks cmc)
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in32
1 files changed, 16 insertions, 16 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index 0bc1704a2f52..f269ea1f0246 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2007-07-31 13:09:29 $
+dnl * Date: $Date: 2007-08-02 14:58:57 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.214 $ )
+AC_REVISION( $Revision: 1.215 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -189,10 +189,6 @@ AC_ARG_ENABLE(gtk,
[ --disable-gtk Determines whether to use Gtk+ vclplug on platforms
where Gtk+ is available.
],,enable_gtk=yes)
-AC_ARG_ENABLE(headless,
-[ --disable-headless Determines whether to use headless vclplug on
- platforms where Glib is available.
-],,enable_headless=yes)
AC_ARG_ENABLE(systray,
[ --disable-systray Determines whether to build the systray quickstarter.
],,enable_systray=yes)
@@ -200,6 +196,10 @@ AC_ARG_ENABLE(cairo,
[ --enable-cairo Determines whether to use Cairo canvas backend on
platforms where Cairo is available.
],,enable_cairo=no)
+AC_ARG_ENABLE(dbus,
+[ --enable-dbus Determines whether to enable presentation mode
+ screensaver control under GNOME via DBUS
+],,enable_dbus=no)
AC_ARG_ENABLE(gnome-vfs,
[ --disable-gnome-vfs Determines whether to use the Gnome Virtual Filing
System on platforms where that VFS is available
@@ -4626,13 +4626,6 @@ if test "x$enable_gtk" = "xyes"; then
fi
AC_SUBST(ENABLE_GTK)
-ENABLE_HEADLESS=""
-if test "x$enable_headless" = "xyes"; then
- ENABLE_HEADLESS="TRUE"
- R="$R svp"
-fi
-AC_SUBST(ENABLE_HEADLESS)
-
ENABLE_KDE=""
if test "x$enable_kde" = "xyes"; then
ENABLE_KDE="TRUE"
@@ -4669,6 +4662,7 @@ dnl ===================================================================
GTK_CFLAGS=""
GTK_LIBS=""
ENABLE_SYSTRAY_GTK=""
+ENABLE_DBUS=""
if test "$test_gtk" = "yes"; then
if test "$ENABLE_GTK" = "TRUE" ; then
@@ -4679,13 +4673,19 @@ if test "$test_gtk" = "yes"; then
ENABLE_SYSTRAY_GTK="TRUE"
BUILD_TYPE="$BUILD_TYPE SYSTRAY_GTK"
fi
- fi
- if test "$ENABLE_HEADLESS" = "TRUE" ; then
- PKG_CHECK_MODULES(GLIB, glib-2.0 ,,AC_MSG_ERROR([requirements to build the headless-plugin not met. Use --disable-headless or install the missing packages]))
+ AC_MSG_CHECKING([whether to enable DBUS support])
+ if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_dbus" = "yes"; then
+ ENABLE_DBUS="TRUE"
+ AC_MSG_RESULT([yes])
+ PKG_CHECK_MODULES( DBUS, dbus-glib-1 >= 0.70 )
+ else
+ AC_MSG_RESULT([no])
+ fi
fi
fi
+AC_SUBST(ENABLE_DBUS)
AC_SUBST(ENABLE_SYSTRAY_GTK)
AC_SUBST(GTK_CFLAGS)
AC_SUBST(GTK_LIBS)