summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorVladimir Glazounov <vg@openoffice.org>2007-05-25 10:09:50 +0000
committerVladimir Glazounov <vg@openoffice.org>2007-05-25 10:09:50 +0000
commit687c22542ba7cdc92c594359075cd54d684c3752 (patch)
tree12ba9b96068475a43fccdb0729d2c90d3015f850 /config_office/configure.in
parentfcc155ebc6b21aa36abd9fc7c7a938b93337fb70 (diff)
INTEGRATION: CWS mingwport04 (1.198.6); FILE MERGED
2007/05/16 15:25:22 vg 1.198.6.3: #i75844# MinGW port efforts part II 2007/05/14 14:07:57 vg 1.198.6.2: #i75844# MinGW port efforts part II 2007/04/17 13:23:08 vg 1.198.6.1: #i75844# MinGW port efforts part 2
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in46
1 files changed, 23 insertions, 23 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index 18345507d552..d059442e7326 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2007-05-10 16:40:23 $
+dnl * Date: $Date: 2007-05-25 11:09:50 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.204 $ )
+AC_REVISION( $Revision: 1.205 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -976,15 +976,6 @@ else
fi
AC_SUBST(DISABLE_STRIP)
-AC_SYS_LARGEFILE
-if test -n "$ac_cv_sys_file_offset_bits"; then
- LFS_CFLAGS="-D_FILE_OFFSET_BITS=$ac_cv_sys_file_offset_bits"
-fi
-if test -n "$ac_cv_sys_large_files" && test "$ac_cv_sys_large_files" != "no"; then
- LFS_CFLAGS="$LFS_CFLAGS -D_LARGE_FILES"
-fi
-AC_SUBST(LFS_CFLAGS)
-
dnl ===================================================================
dnl Build options
dnl ===================================================================
@@ -1129,6 +1120,15 @@ AC_MSG_RESULT([$USE_SHELL])
AC_SUBST(USE_SHELL)
AC_SUBST(WITH_MINGWIN)
+AC_SYS_LARGEFILE
+if test -n "$ac_cv_sys_file_offset_bits"; then
+ LFS_CFLAGS="-D_FILE_OFFSET_BITS=$ac_cv_sys_file_offset_bits"
+fi
+if test -n "$ac_cv_sys_large_files" && test "$ac_cv_sys_large_files" != "no"; then
+ LFS_CFLAGS="$LFS_CFLAGS -D_LARGE_FILES"
+fi
+AC_SUBST(LFS_CFLAGS)
+
dnl ===================================================================
dnl Extra check for Windows. Non 4nt-builds need gcc to build dmake
dnl and g++ to build guw.exe although MS cl (or MinGW) is used to
@@ -1799,26 +1799,26 @@ if test "$WITH_MINGWIN" = "yes"; then
#include <stddef.h>
#include <bits/c++config.h>
_ACEOF
- _lib_include_path=`$CXX -E -xc++ conftest.$ac_ext | $SED -n -e '/.*1*"\(.*\)\/stddef.h".*/s//\1/p' -e '/.*1*"\(.*\)\/bits\/c++config.h".*/s//\1/p' | sort -u | xargs echo`
+ _mingw_lib_include_path=`$CXX -E -xc++ conftest.$ac_ext | $SED -n -e '/.*1*"\(.*\)\/stddef.h".*/s//\1/p' -e '/.*1*"\(.*\)\/bits\/c++config.h".*/s//\1/p' | sort -u | xargs echo`
rm conftest.$ac_ext
- if test -n "$_lib_include_path"; then
+ if test -n "$_mingw_lib_include_path"; then
_temp=""
- for a in $_lib_include_path
+ for a in $_mingw_lib_include_path
do
a=`cygpath -d "$a"`
_temp="$_temp "`cygpath -u "$a"`
done
- _lib_include_path=$_temp
+ _mingw_lib_include_path=$_temp
fi
+ if test -z "$_mingw_lib_include_path"; then
+ _mingw_lib_include_path="NO_LIB_INCLUDE"
+ AC_MSG_RESULT([no mingwin runtime includes])
+ else
+ AC_MSG_RESULT([$_mingw_lib_include_path])
+ fi
+MINGW_LIB_INCLUDE_PATH="$_mingw_lib_include_path"
+AC_SUBST(MINGW_LIB_INCLUDE_PATH)
fi
-if test -z "$_lib_include_path"; then
- _lib_include_path="NO_LIB_INCLUDE"
- AC_MSG_RESULT([no mingwin runtime includes])
-else
- AC_MSG_RESULT([$_lib_include_path])
-fi
-LIB_INCLUDE_PATH="$_lib_include_path"
-AC_SUBST(LIB_INCLUDE_PATH)
dnl ===================================================================
dnl Extra checking for the SUN OS compiler