summaryrefslogtreecommitdiff
path: root/config_office/configure.in
diff options
context:
space:
mode:
authorKurt Zenker <kz@openoffice.org>2007-05-10 15:40:23 +0000
committerKurt Zenker <kz@openoffice.org>2007-05-10 15:40:23 +0000
commit5a2d55ad4dce79ad626aef1f97e65400b7a84f7d (patch)
treee417569a157dc4fabced280b6ab95b2756e29b5c /config_office/configure.in
parentbb71f7e2d5747fbdc1172af7f85e658da8421367 (diff)
INTEGRATION: CWS pchfix04 (1.187.2); FILE MERGED
2007/04/26 03:54:39 hjs 1.187.2.8: RESYNC: (1.197-1.199); FILE MERGED 2007/02/13 16:22:40 hjs 1.187.2.7: RESYNC: (1.196-1.197); FILE MERGED 2007/01/26 20:25:47 hjs 1.187.2.6: RESYNC: (1.190-1.196); FILE MERGED 2006/12/22 12:52:07 hjs 1.187.2.5: RESYNC: (1.189-1.190); FILE MERGED 2006/12/13 15:11:36 kaib 1.187.2.4: #i71519# Reverting my second addition of --enable-pch to configure.in 2006/12/13 14:38:19 kaib 1.187.2.3: #i71519# added --enable-pch option to configure 2006/12/11 14:49:28 kaib 1.187.2.2: RESYNC: (1.187-1.189); FILE MERGED 2006/11/16 10:13:30 mkretzschmar 1.187.2.1: #i71588# Make precompiled headers possible for gcc >= 3.4.
Diffstat (limited to 'config_office/configure.in')
-rw-r--r--config_office/configure.in51
1 files changed, 27 insertions, 24 deletions
diff --git a/config_office/configure.in b/config_office/configure.in
index 886da2218c02..18345507d552 100644
--- a/config_office/configure.in
+++ b/config_office/configure.in
@@ -3,7 +3,7 @@ dnl * vi:set sw=3 ts=3 et:
dnl *
dnl * Name: configure.in
dnl * Auth: Willem van Dorp, Ross Nicholson, Oisin Boydell - Sun Microsystems Ireland
-dnl * Date: $Date: 2007-05-10 13:15:13 $
+dnl * Date: $Date: 2007-05-10 16:40:23 $
dnl *
dnl * Desc: This file serves as input for the GNU autoconf package
dnl * in order to create a configure script.
@@ -12,7 +12,7 @@ dnl * necessary to build OpenOffice.org
dnl *
dnl *
dnl ******************************************************************/
-AC_REVISION( $Revision: 1.203 $ )
+AC_REVISION( $Revision: 1.204 $ )
AC_PREREQ(2.50)
AC_INIT()
echo "$@" >config.parms
@@ -57,7 +57,7 @@ AC_ARG_WITH(vba-package-format,
--with-package-format="extsn"
],,)
AC_ARG_ENABLE(pch,
-[ --enable-pch Enables the use of precompiledr C/C++ header files
+[ --enable-pch EXPERIMENTAL: Enables precompiled header support for C++.
],,)
AC_ARG_ENABLE(libsn,
[ --enable-libsn Enables the use of libstartup-notification
@@ -622,8 +622,7 @@ AC_ARG_WITH(alloc,
],,)
AC_ARG_ENABLE(jam-build,
-[ --enable-jam Enables the !prototype! jam build system that can be
- used with the standard build.
+[ --enable-jam EXPERIMENTAL: Enables the prototype jam build system
],,)
BUILD_TYPE="OOo EXT"
@@ -859,24 +858,6 @@ else
fi
AC_SUBST(ENABLE_CRASHDUMP)
-dnl ===================================================================
-dnl Set the ENABLE_PCH variable. (Activate --enable-pch)
-dnl ===================================================================
-AC_MSG_CHECKING([whether to enable pch feature])
-if test -n "$enable_pch" && test "$enable_pch" != "no"; then
- if test "$_os" = "WINNT" -a "$WITH_MINGWIN" != "yes"; then
- ENABLE_PCH="TRUE"
- AC_MSG_RESULT([yes])
- else
- ENABLE_PCH=""
- AC_MSG_WARN([Precompiled header not yet supported for your platform/compiler])
- fi
-else
- ENABLE_PCH=""
- AC_MSG_RESULT([no])
-fi
-AC_SUBST(ENABLE_PCH)
-
if test "$_os" = "WINNT"; then
BUILD_TYPE="$BUILD_TYPE TWAIN"
fi
@@ -1263,6 +1244,28 @@ fi
AC_SUBST(HAVE_GCC_VISIBILITY_FEATURE)
dnl ===================================================================
+dnl Set the ENABLE_PCH variable. (Activate --enable-pch)
+dnl ===================================================================
+AC_MSG_CHECKING([whether to enable pch feature])
+if test -n "$enable_pch" && test "$enable_pch" != "no"; then
+ if test "$_os" = "WINNT" -a "$WITH_MINGWIN" != "yes"; then
+ ENABLE_PCH="TRUE"
+ AC_MSG_RESULT([yes])
+dnl There is no PCH support in GCC versions prior to this
+ elif test "$GCC" = "yes" -a "$GCCVER" -gt "030400"; then
+ ENABLE_PCH="TRUE"
+ AC_MSG_RESULT([yes])
+ else
+ ENABLE_PCH=""
+ AC_MSG_WARN([Precompiled header not yet supported for your platform/compiler])
+ fi
+else
+ ENABLE_PCH=""
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_PCH)
+
+dnl ===================================================================
dnl Search all the common names for GNU make
dnl ===================================================================
AC_MSG_CHECKING([for GNU make])
@@ -5204,7 +5207,7 @@ fi
AC_SUBST(ENABLE_STATIC_GTK)
dnl ===================================================================
-dnl Test if we should enable the prototype jam build
+dnl Test if we should enable the experimental jam build
dnl ===================================================================
AC_MSG_CHECKING([whether to enable prototype jam build])