summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorsb <sb@openoffice.org>2009-12-07 09:34:25 +0100
committersb <sb@openoffice.org>2009-12-07 09:34:25 +0100
commit5a6612788cb677a704c31a8b989f82eefdd0d5f0 (patch)
tree62ddc3b1c399135888083732b1c623bd09be782c /configure.in
parent928c4b55dbcbc11f621a08d3d92e7e1e9ca95f3f (diff)
parentf9e11eb3f7c046f6a07d0b6c96b5c14c7204fc6e (diff)
merged in DEV300_m66
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in50
1 files changed, 24 insertions, 26 deletions
diff --git a/configure.in b/configure.in
index bce4a1bfc..6217774bd 100644
--- a/configure.in
+++ b/configure.in
@@ -130,7 +130,7 @@ AC_ARG_ENABLE(evolution2,
],,)
AC_ARG_WITH(system-stdlibs,
[ --with-system-stdlibs use libstdc++/libgcc_s already on system
-],,checkforprelink=yes)
+],,checkforstdlibproblems=yes)
AC_ARG_WITH(system-mspack,
[ --with-system-mspack use libmspack already installed on system
],,)
@@ -773,9 +773,8 @@ AC_ARG_WITH(use-shell,
Supported options:
tcsh (default)
bash
- 4nt (windows only)
- Usage: --with-use-shell=tcsh|bash|4nt
+ Usage: --with-use-shell=tcsh|bash
],with_use_shell=$withval,with_use_shell="tcsh")
AC_ARG_WITH(build-version,
[ --with-build-version Allows the builder to add a custom version tag
@@ -1302,14 +1301,14 @@ AC_SUBST(HYPH_SYSTEM_DIR)
AC_SUBST(THES_SYSTEM_DIR)
dnl ===================================================================
-dnl WINNT uses tcsh, bash or 4nt all other O/S use tcsh or bash.
+dnl all O/S use tcsh or bash.
dnl The following sets the with_use_shell variable.
dnl ===================================================================
AC_MSG_CHECKING([which shell to use])
if test $_os = "WINNT"; then
dnl ===================================================================
- if test "$with_use_shell" != "tcsh" -a "$with_use_shell" != "bash" -a "$with_use_shell" != "4nt"; then
- AC_MSG_ERROR([only "tcsh","bash" or "4nt" are supported options])
+ if test "$with_use_shell" != "tcsh" -a "$with_use_shell" != "bash"; then
+ AC_MSG_ERROR([only "tcsh" or "bash" are supported options])
fi
dnl ===================================================================
dnl Sanity check! Native windows programs cannot use cygwin symlinks!
@@ -1341,7 +1340,7 @@ link, and copy the program to the name of the link.])
dnl If using Mingwin32 then don't use 4NT
dnl ===================================================================
if test "$WITH_MINGWIN" = "yes" ; then
- if test "$with_use_shell" = "4nt" -o "x$with_use_shell" = "x"; then
+ if test "x$with_use_shell" = "x"; then
with_use_shell="tcsh"
fi
if test -z "$CC"; then
@@ -1350,8 +1349,8 @@ link, and copy the program to the name of the link.])
fi
fi
elif test $_os = "OS2"; then
- if test "$with_use_shell" != "tcsh" -a "$with_use_shell" != "4nt"; then
- AC_MSG_ERROR([only "tcsh" or "4nt" are supported options])
+ if test "$with_use_shell" != "tcsh"; then
+ AC_MSG_ERROR([only "tcsh" is supported options])
fi
else
dnl ===================================================================
@@ -1367,11 +1366,11 @@ AC_SUBST(USE_SHELL)
AC_SUBST(WITH_MINGWIN)
dnl ===================================================================
-dnl Extra check for Windows. Non 4nt-builds need gcc to build dmake
+dnl Extra check for Windows. cygwin builds need gcc to build dmake
dnl and g++ to build guw.exe although MS cl (or MinGW) is used to
dnl build OOo.
dnl ===================================================================
-if test "$_os" = "WINNT" -a "$with_use_shell" != "4nt" ; then
+if test "$_os" = "WINNT" ; then
AC_MSG_CHECKING([for cygwin gcc/g++])
if which gcc > /dev/null && which g++ > /dev/null ; then
AC_MSG_RESULT([found])
@@ -2625,7 +2624,7 @@ _ACEOF
if ! $CXX $CXXFLAGS $CPPFLAGS -fpic -S visibility.cxx 2>/dev/null > /dev/null; then
gccvisbroken=yes
else
- if $EGREP -q '@PLT|\$stub' visibility.s; then
+ if $EGREP -q '@PLT|\$stub|\(PLT\)' visibility.s; then
gccvisbroken=no;
else
gccvisbroken=yes;
@@ -2805,8 +2804,8 @@ if test "$SOLAR_JAVA" != ""; then
_jdk=`$JAVAINTERPRETER -version 2>&1 | $AWK -F'"' '{ print \$2 }' | $SED s/[[-A-Za-z]]*//`
_jdk_ver=`echo "$_jdk" | $AWK -F. '{ print (($1 * 100) + $2) * 100 + $3;}'`
- if test "$_jdk_ver" -lt 10600; then
- AC_MSG_ERROR([IBM JDK is too old, you need at least 1.6])
+ if test "$_jdk_ver" -lt 10500; then
+ AC_MSG_ERROR([IBM JDK is too old, you need at least 1.5])
fi
AC_MSG_RESULT([checked (IBM JDK $_jdk)])
@@ -3494,10 +3493,16 @@ dnl ===================================================================
dnl Check for prelinked libgcc_s.so.1
dnl ===================================================================
if test -z "$with_system_stdlibs" -a -z "$with_system_libs"; then
- if test -n "$checkforprelink" -a -f /etc/rpm/macros.prelink; then
- with_system_stdlibs=yes
- AC_MSG_WARN([prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
- echo "prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
+ if test -n "$checkforstdlibproblems"; then
+ if test -f /etc/rpm/macros.prelink; then
+ with_system_stdlibs=yes
+ AC_MSG_WARN([prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
+ echo "prelinked libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
+ elif test "$GCC" = "yes" -a ! -e `$CC -print-file-name=libgcc_s.so.1`; then
+ with_system_stdlibs=yes
+ AC_MSG_WARN([platform doesn't have a libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override])
+ echo "platform doesn't have a libgcc_s.so.1, enabling --with-system-stdlibs, use --without-system-stdlibs to override" >> warn
+ fi
fi
fi
@@ -5240,15 +5245,8 @@ dnl ===================================================================
dnl Zip must be a specific type for different build types.
dnl ===================================================================
if test "$_os" = "WINNT"; then
- if test "$with_use_shell" = "4nt" ; then
- if test -z "`$ZIP -h | grep -i WinNT`" ; then
-AC_MSG_ERROR([$ZIP found in the path is not the required native Windows Version 2.3 of Info-ZIPs zip.exe.
-Probably there is a cygwin version in the path.])
- fi
- else
- if test -n "`$ZIP -h | grep -i WinNT`" ; then
+ if test -n "`$ZIP -h | grep -i WinNT`" ; then
AC_MSG_ERROR([$ZIP found in the path is not the required cygwin version of Info-ZIPs zip.exe.])
- fi
fi
fi
AC_SUBST(ZIP_HOME)