summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorScott D Phillips <scott.d.phillips@intel.com>2016-07-27 10:09:38 -0700
committerVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2016-07-27 19:45:00 +0200
commit971472e9c492c541d0a17fed69b18c5d5a8b6bfc (patch)
tree6accebc857790824084e0858a3decc4903ddedb8 /configure.ac
parent27429ce676e5759c77e8b55b30603161125c14d8 (diff)
configure: Fix non-fatal PKG_CHECK_MODULES invocations
Some invocations of PKG_CHECK_MODULES were intended to be non-fatal if the package is missing, but action-if-not-found was given as an empty string which still causes the default action to run, which halts execution. Signed-off-by: Scott D Phillips <scott.d.phillips@intel.com> https://bugzilla.gnome.org/show_bug.cgi?id=769237
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 994dec16..173f9df5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -282,7 +282,7 @@ GstGLContext gl_context;
CPPFLAGS="$saved_CPPFLAGS"
LIBS="$saved_LIBS"
])
- ], [])
+ ], [:])
fi
AS_IF([test "x$ac_cv_have_gst_gl_helpers" = "xno"], [HAVE_GSTGL=0])
AM_CONDITIONAL([USE_GST_GL_HELPERS], [test $HAVE_GSTGL -eq 1])
@@ -308,7 +308,7 @@ if test "x$enable_drm" = "xyes"; then
CPPFLAGS="$CPPFLAGS $DRM_CFLAGS"
AC_CHECK_HEADERS([drm_fourcc.h], [], [USE_DRM=0])
CPPFLAGS="$saved_CPPFLAGS"
- ], [])
+ ], [:])
fi
dnl Check for X11
@@ -321,7 +321,7 @@ if test "x$enable_x11" = "xyes"; then
CPPFLAGS="$CPPFLAGS $X11_CFLAGS"
AC_CHECK_HEADERS([X11/Xlib.h X11/Xutil.h X11/Xatom.h], [], [USE_X11=0])
CPPFLAGS="$saved_CPPFLAGS"
- ], [])
+ ], [:])
fi
HAVE_XKBLIB=0
@@ -340,7 +340,7 @@ if test $USE_X11 -eq 1; then
CPPFLAGS="$CPPFLAGS $XRANDR_CFLAGS"
AC_CHECK_HEADERS([X11/extensions/Xrandr.h], [], [HAVE_XRANDR=0])
CPPFLAGS="$saved_CPPFLAGS"
- ], [])
+ ], [:])
dnl Check for XRender
PKG_CHECK_MODULES([XRENDER], [xrender],
@@ -350,7 +350,7 @@ if test $USE_X11 -eq 1; then
CPPFLAGS="$CPPFLAGS $XRENDER_CFLAGS"
AC_CHECK_HEADERS([X11/extensions/Xrender.h], [], [HAVE_XRENDER=0])
CPPFLAGS="$saved_CPPFLAGS"
- ], [])
+ ], [:])
fi
AC_DEFINE_UNQUOTED([HAVE_XKBLIB], [$HAVE_XKBLIB],
@@ -465,7 +465,7 @@ if test "x$enable_egl" = "xyes" -a $GLES_VERSION_MASK -ne 0; then
dnl Check for GMODULE
PKG_CHECK_MODULES([GMODULE], [gmodule-2.0 >= $GLIB_REQ])
- ], [])
+ ], [:])
fi
dnl Check for Wayland
@@ -478,7 +478,7 @@ if test "x$enable_wayland" = "xyes"; then
CPPFLAGS="$CPPFLAGS $WAYLAND_CFLAGS"
AC_CHECK_HEADERS([wayland-client.h], [], [USE_WAYLAND=0])
CPPFLAGS="$saved_CPPFLAGS"
- ], [])
+ ], [:])
fi
dnl ---------------------------------------------------------------------------
@@ -722,7 +722,7 @@ if test "x$enable_encoders" = "xyes"; then
#include <va/va.h>
])
CPPFLAGS="$saved_CPPFLAGS"
- ], [])
+ ], [:])
fi
USE_JPEG_ENCODER=0