summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2016-06-28 11:33:18 +0200
committerVíctor Manuel Jáquez Leal <victorx.jaquez@intel.com>2016-07-22 17:23:23 +0200
commit1cba2f363385914e2c6cc445d19834c41f56a6e3 (patch)
treeaa6123b7a0fa6b382c4d9fd14b755430aa5d809b /configure.ac
parent024d5401955d4d7b1348ba5f68180719640aa93c (diff)
vaapi: declare external dependencies
There are two main external dependencies that define the feature set of this plugin: a) the kernel and b) the VA driver This patch tracks both dependencies, if any of them change, GStreamer will re-inspect the plugin. The kernel is tracked through the device files /dev/dri/card* The VA driver is tracked through the files VA_DRIVERS_PATH/*_drv_video.so, where VA_DRIVERS_PATH is the one defined in libva package configuration. Also, the environment variables LIBVA_DRIVERS_PATH and LIBVA_DRIVER_NAME are tracked since they modify the driver lookup. Additionally, the environment variable GST_VAAPI_ALL_DRIVERS is tracked too. https://bugzilla.gnome.org/show_bug.cgi?id=724352
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c4efc9f9..994dec16 100644
--- a/configure.ac
+++ b/configure.ac
@@ -488,6 +488,9 @@ dnl ---------------------------------------------------------------------------
dnl Core API
PKG_CHECK_MODULES([LIBVA], [libva >= $VAAPI_REQ])
VA_VERSION_STR=`$PKG_CONFIG --modversion libva`
+VA_DRIVERS_PATH=`$PKG_CONFIG --variable=driverdir libva`
+AC_DEFINE_UNQUOTED([VA_DRIVERS_PATH], ["$VA_DRIVERS_PATH"],
+ [VA drivers path])
dnl VA/DRM API
if test $USE_DRM -eq 1; then