summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2017-08-10 13:09:27 +0200
committerVíctor Manuel Jáquez Leal <vjaquez@igalia.com>2017-08-13 18:08:19 +0200
commit1789c6090fa9781fd9887db18b475a32e476bf46 (patch)
tree1062e07c1375dacb6bb70e22d6a7d21bd20c91ba /configure.ac
parent93c7c9c3f426aa1be278c5cf8e6d5dd54f12b964 (diff)
build: check for va_vpp.h
Thus, in config.h the macro HAVE_VA_VA_VPP_H is defined. This will allow us to handle the inclusion of the header better. https://bugzilla.gnome.org/show_bug.cgi?id=786119
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index ce1e0234..efa7bdc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -709,6 +709,15 @@ slice_param.slice_data_flag = 0;
])
AS_IF([test "x$ac_cv_have_h265_decoding_api" = "xyes"], [USE_H265_DECODER=1])
+dnl Check for va_vpp.h header
+saved_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $LIBVA_CFLAGS"
+AC_CHECK_HEADERS([va/va_vpp.h], [], [],
+ [
+#include <va/va.h>
+ ])
+CPPFLAGS="$saved_CPPFLAGS"
+
dnl Check for vpp (video post-processing) support
USE_VA_VPP=0
AC_CACHE_CHECK([for video post-postprocessing API],
@@ -723,7 +732,9 @@ AC_CACHE_CHECK([for video post-postprocessing API],
AC_LANG_PROGRAM(
[[
#include <va/va.h>
-#include <va/va_vpp.h>
+#ifdef HAVE_VA_VA_VPP_H
+# include <va/va_vpp.h>
+#endif
]],
[[
VADisplay va_dpy;