summaryrefslogtreecommitdiff
path: root/examples/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@collabora.co.uk>2013-07-11 10:28:06 +0200
committerWim Taymans <wim.taymans@collabora.co.uk>2013-07-11 10:28:06 +0200
commit2fdc6ef88ad267284fb408bdc2a44dbc85a4f1d2 (patch)
tree1e54b3ff054e52ab78c764491d824313ba8a3ed8 /examples/Makefile.am
parent5c6bb3052fa79f2359fa9f712917086a016f4775 (diff)
configure: compile cgroup example conditionally
Only compile the cgroup example when we have libcgroup
Diffstat (limited to 'examples/Makefile.am')
-rw-r--r--examples/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/examples/Makefile.am b/examples/Makefile.am
index 20b6cb9..deec57c 100644
--- a/examples/Makefile.am
+++ b/examples/Makefile.am
@@ -1,8 +1,14 @@
noinst_PROGRAMS = test-video test-ogg test-mp4 test-readme \
test-launch test-sdp test-uri test-auth \
- test-multicast test-multicast2 test-cgroups
+ test-multicast test-multicast2
#INCLUDES = -I$(top_srcdir) -I$(srcdir)
AM_CFLAGS = $(GST_OBJ_CFLAGS)
-AM_LDFLAGS = $(GST_OBJ_LIBS) $(GIO_LIBS) $(LIBCGROUP_LIBS)
+AM_LDFLAGS = $(GST_OBJ_LIBS) $(GIO_LIBS)
+
+if HAVE_LIBCGROUP
+noinst_PROGRAMS += test-cgroups
+AM_LDFLAGS += $(LIBCGROUP_LIBS)
+endif
+