summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2017-12-26 13:51:37 +0100
committerTim-Philipp Müller <tim@centricular.com>2017-12-26 13:51:37 +0100
commitc9baaf3e50d3e5870b86b41776b418630ed3db8f (patch)
tree7e519031ba507659adabcea8934d0d7e19fa2cc7 /meson.build
parenta98d2a8ecc226b19fbd9a2a38e06f3c7a7202016 (diff)
meson: skip translations if gettext is not available
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 7c29a7a2..eb96b7ba 100644
--- a/meson.build
+++ b/meson.build
@@ -197,7 +197,11 @@ presetdir = join_paths(get_option('datadir'), 'gstreamer-' + api_version, 'prese
subdir('gst')
subdir('ext')
subdir('tests')
-subdir('po')
+
+# xgettext is optional (on Windows for instance)
+if find_program('xgettext', required : false).found()
+ subdir('po')
+endif
python3 = import('python3').find_python()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')