summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNiels De Graef <niels.degraef@barco.com>2019-05-31 23:07:58 +0200
committerNiels De Graef <niels.degraef@barco.com>2019-06-02 21:27:12 +0200
commit985ace70e05f664d13e268cf0fb135d19b29fff8 (patch)
tree449da433602630110b639ca23beb75c1f0b009dc /meson.build
parentdd96c2a98903c0299a945d53cbc481c0b93ae7d5 (diff)
meson: Bump minimal GLib version to 2.44
This means we can use some newer features and get rid of some boilerplate code using the G_DECLARE_* macros. As discussed on IRC, 2.44 is old enough by now to start depending on it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 9d28a5e8..edb75e93 100644
--- a/meson.build
+++ b/meson.build
@@ -18,7 +18,7 @@ gst_version_is_dev = gst_version_minor % 2 == 1 and gst_version_micro < 90
have_cxx = add_languages('cpp', required : false)
-glib_req = '>= 2.40.0'
+glib_req = '>= 2.44.0'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
api_version = '1.0'