summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSeungha Yang <seungha.yang@navercorp.com>2018-11-24 19:28:19 +0900
committerSeungha Yang <seungha.yang@navercorp.com>2018-11-24 19:28:19 +0900
commit8f65ea458baf8e2abf66d2e0f232cc3de020bc61 (patch)
tree0a4557f2e090f64ca4b48ac78429761e4d861938 /meson.build
parent59d43105c77696e881ef73f5427354f1733b3c32 (diff)
meson: Specify encoding to UTF-8 when building with MSVC
Use build arguments consistent with core and -base. This can also remove noisy "C4819" warning of non-us locale MSVC.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 6f7cbeda..e45b75d9 100644
--- a/meson.build
+++ b/meson.build
@@ -40,6 +40,7 @@ if cc.get_id() == 'msvc'
'/wd4146', # unary minus on unsigned (beware INT_MIN)
'/wd4244', # lossy type conversion (e.g. double -> int)
'/wd4305', # truncating type conversion (e.g. double -> float)
+ cc.get_supported_arguments(['/utf-8']), # set the input encoding to utf-8
language : 'c')
# Disable SAFESEH with MSVC for plugins and libs that use external deps that
# are built with MinGW