summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian@centricular.com>2019-04-22 12:51:33 +0300
committerSebastian Dröge <sebastian@centricular.com>2019-04-22 12:51:33 +0300
commit8c994a632b5190b41a66da37bb4508aff198ed10 (patch)
treea00e2d30ab6381a9d231fca6036ef2507492d89e /meson.build
parent7107fc5214688eee329ae47180e09200cb2904da (diff)
meson: Always require the gmodule dependency
It's needed by the dvdread plugin but also by the x264 plugin in certain circumstances. As it's part of GLib and always available, simply move it as a hard dependency to the top-level meson.build.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 092aaa17..0526f628 100644
--- a/meson.build
+++ b/meson.build
@@ -155,6 +155,8 @@ else
cdata.set('DISABLE_ORC', 1)
endif
+gmodule_dep = dependency('gmodule-2.0', fallback : ['glib', 'libgmodule_dep'])
+
ugly_args = ['-DHAVE_CONFIG_H']
configinc = include_directories('.')
libsinc = include_directories('gst-libs')