summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@centricular.com>2020-05-12 05:07:47 +0530
committerNirbheek Chauhan <nirbheek@centricular.com>2020-05-12 05:07:47 +0530
commit8562bb304d7ec86201a7c496fae1072e96404351 (patch)
tree59caf8c34719b37c9ad9fe8964dc59e8a3b911ca /meson.build
parent8fe8ed3dd2bdcf22097d9886ad5242258b64ee44 (diff)
meson: Pass native: false to add_languages()
This is needed for cross-compiling without a build machine compiler available. The option was added in 0.54, but we only need this in Cerbero and it doesn't affect older versions so it should be ok. Will just cause a spurious warning. Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-ugly/-/merge_requests/50>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index edb75e93..a3a78add 100644
--- a/meson.build
+++ b/meson.build
@@ -16,7 +16,7 @@ else
endif
gst_version_is_dev = gst_version_minor % 2 == 1 and gst_version_micro < 90
-have_cxx = add_languages('cpp', required : false)
+have_cxx = add_languages('cpp', native: false, required: false)
glib_req = '>= 2.44.0'
gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)