summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-08-18 21:22:42 +0100
committerTim-Philipp Müller <tim@centricular.com>2018-08-18 21:27:24 +0100
commit71a35e7c8b82b163a2370aeaf4dd62800cf90a7c (patch)
tree8071e375a749a98db0cd17db8b8ea7080c4d4ca1 /meson.build
parent0f86a27df9ea0dc515ba9cc80c974cd15fe1d05a (diff)
meson: add option to disable tests
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e6d11f52..9013477d 100644
--- a/meson.build
+++ b/meson.build
@@ -142,6 +142,7 @@ gstrtsp_dep = dependency('gstreamer-rtsp-1.0', version : gst_req,
fallback : ['gst-plugins-base', 'rtsp_dep'])
if host_machine.system() != 'windows'
gstcheck_dep = dependency('gstreamer-check-1.0', version : gst_req,
+ required : get_option('tests'),
fallback : ['gstreamer', 'gst_check_dep'])
endif
gstcontroller_dep = dependency('gstreamer-controller-1.0', version : gst_req,