summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorXavier Claessens <xavier.claessens@collabora.com>2018-04-24 14:06:20 -0400
committerTim-Philipp Müller <tim@centricular.com>2018-04-25 11:07:39 +0100
commit6b01999087b804847d8d2a3862831a5cef0947a4 (patch)
tree309f12ca521343ccb4df2c87c76db680aecab556 /meson.build
parenta76c63ba38b64231d8053acf7abe36db0f28c2bf (diff)
Meson: Generate pc file for all plugins in ugly
https://bugzilla.gnome.org/show_bug.cgi?id=794568
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 8c55605e..cc6632f9 100644
--- a/meson.build
+++ b/meson.build
@@ -235,6 +235,14 @@ foreach extra_arg : warning_c_flags
endforeach
presetdir = join_paths(get_option('datadir'), 'gstreamer-' + api_version, 'presets')
+
+pkgconfig = import('pkgconfig')
+plugins_pkgconfig_install_dir = join_paths(plugins_install_dir, 'pkgconfig')
+if get_option('default_library') == 'shared'
+ # If we don't build static plugins there is no need to generate pc files
+ plugins_pkgconfig_install_dir = disabler()
+endif
+
subdir('gst')
subdir('ext')
subdir('tests')