summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <tsaunier@igalia.com>2018-10-22 11:47:37 +0200
committerThibault Saunier <tsaunier@igalia.com>2019-05-13 17:00:00 -0400
commit21ac37c61aac558c7f3ca11a43f12cc475422503 (patch)
tree5a309993fce329284079a501689a75cf4d852262 /meson.build
parent2df9f6e5ce49f975cecfb94cd925cb83b3552522 (diff)
docs: Port documentation to hotdoc
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 0526f628..9d28a5e8 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,6 @@
project('gst-plugins-ugly', 'c',
version : '1.17.0.1',
- meson_version : '>= 0.47',
+ meson_version : '>= 0.48',
default_options : [ 'warning_level=1',
'buildtype=debugoptimized' ])
@@ -24,6 +24,7 @@ gst_req = '>= @0@.@1@.0'.format(gst_version_major, gst_version_minor)
api_version = '1.0'
plugins_install_dir = join_paths(get_option('libdir'), 'gstreamer-1.0')
+plugins = []
cc = meson.get_compiler('c')
if have_cxx
@@ -256,6 +257,7 @@ if get_option('default_library') == 'shared'
plugins_pkgconfig_install_dir = disabler()
endif
+python3 = import('python').find_installation()
subdir('gst')
subdir('ext')
subdir('tests')
@@ -265,8 +267,8 @@ if find_program('xgettext', required : get_option('nls')).found()
cdata.set('ENABLE_NLS', 1)
subdir('po')
endif
+subdir('docs')
configure_file(output : 'config.h', configuration : cdata)
-python3 = import('python').find_installation()
run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')