summaryrefslogtreecommitdiff
path: root/ext/dash/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'ext/dash/meson.build')
-rw-r--r--ext/dash/meson.build20
1 files changed, 20 insertions, 0 deletions
diff --git a/ext/dash/meson.build b/ext/dash/meson.build
new file mode 100644
index 000000000..8d31bc375
--- /dev/null
+++ b/ext/dash/meson.build
@@ -0,0 +1,20 @@
+dash_sources = [
+ 'gstdashdemux.c',
+ 'gstisoff.c',
+ 'gstmpdparser.c',
+ 'gstplugin.c',
+]
+
+xml2_dep = dependency('libxml-2.0', version : '>= 2.8', required : false)
+if xml2_dep.found()
+ gstsouphttpsrc = library('gstdashdemux',
+ dash_sources,
+ c_args : gst_plugins_bad_args + ['-DGST_USE_UNSTABLE_API'],
+ link_args : noseh_link_args,
+ include_directories : [configinc, libsinc],
+ dependencies : [gstadaptivedemux_dep, gsturidownloader_dep, gsttag_dep,
+ gstnet_dep, gstbase_dep, gio_dep, xml2_dep],
+ install : true,
+ install_dir : plugins_install_dir,
+ )
+endif