summaryrefslogtreecommitdiff
path: root/gst-libs/gst/gl/x11/Makefile.am
diff options
context:
space:
mode:
authorMatthew Waters <ystreet00@gmail.com>2013-08-15 17:09:04 +1000
committerMatthew Waters <ystreet00@gmail.com>2014-03-15 18:37:01 +0100
commit95c08c2ee20b4872dd0cdbd086d2d9f37b0c7311 (patch)
treec9510ec5117aa9e973fbd5b230d08eb0e3efc2d7 /gst-libs/gst/gl/x11/Makefile.am
parentcf5e910d9b25d5d3e5633831be7c9a51507c12a3 (diff)
[794/906] context: add subclasses for the different platforms (egl, glx, wgl, etc)
- most code taken from the Window subclasses - tested combinations: xEGL, GLX, Wayland+EGL, Cocoa (under GNUStep), WGL (Wine)
Diffstat (limited to 'gst-libs/gst/gl/x11/Makefile.am')
-rw-r--r--gst-libs/gst/gl/x11/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/gst-libs/gst/gl/x11/Makefile.am b/gst-libs/gst/gl/x11/Makefile.am
index 0dbcb4482..e5db6d052 100644
--- a/gst-libs/gst/gl/x11/Makefile.am
+++ b/gst-libs/gst/gl/x11/Makefile.am
@@ -11,14 +11,15 @@ noinst_HEADERS = \
x11_event_source.h
if USE_GLX
-libgstgl_x11_la_SOURCES += gstglwindow_x11_glx.c
-noinst_HEADERS += gstglwindow_x11_glx.h
-endif
-if USE_EGL
-libgstgl_x11_la_SOURCES += gstglwindow_x11_egl.c
-noinst_HEADERS += gstglwindow_x11_egl.h
+libgstgl_x11_la_SOURCES += gstglcontext_glx.c
+noinst_HEADERS += gstglcontext_glx.h
endif
+#if USE_EGL
+#libgstgl_x11_la_SOURCES += gstglwindow_x11_egl.c
+#noinst_HEADERS += gstglwindow_x11_egl.h
+#endif
+
libgstgl_x11_la_CFLAGS = \
-I$(top_srcdir)/gst-libs \
$(GL_CFLAGS) \