summaryrefslogtreecommitdiff
path: root/ext/openexr/meson.build
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim@centricular.com>2018-12-17 00:11:16 +0000
committerSebastian Dröge <slomo@coaxion.net>2018-12-17 09:12:53 +0000
commit79d8855d879b3ec7b6f1e851b2a4dd05f572eccc (patch)
tree3bcce341fa7ee141d553644800bd8e481718cee2 /ext/openexr/meson.build
parentc23a1dc2b663b81c0233d0396af9b343c95ba2c4 (diff)
meson: build openexr plugin
Diffstat (limited to 'ext/openexr/meson.build')
-rw-r--r--ext/openexr/meson.build16
1 files changed, 16 insertions, 0 deletions
diff --git a/ext/openexr/meson.build b/ext/openexr/meson.build
new file mode 100644
index 000000000..7f4bab750
--- /dev/null
+++ b/ext/openexr/meson.build
@@ -0,0 +1,16 @@
+openexr_dep = dependency('OpenEXR', required: get_option('openexr'))
+if openexr_dep.found()
+ openexr_extra_cpp_args = cxx.get_supported_arguments(['-std=c++98'])
+ gstopenexr = library('gstopenexr',
+ 'gstopenexr.c',
+ 'gstopenexrdec.cpp',
+ c_args: gst_plugins_bad_args,
+ cpp_args: gst_plugins_bad_args + openexr_extra_cpp_args,
+ link_args: noseh_link_args,
+ include_directories: [configinc, libsinc],
+ dependencies: [gstvideo_dep, openexr_dep],
+ install: true,
+ install_dir: plugins_install_dir,
+ )
+ pkgconfig.generate(gstopenexr, install_dir: plugins_pkgconfig_install_dir)
+endif