summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-04-07 13:43:33 +0100
committerSimon McVittie <smcv@collabora.com>2017-04-10 12:40:19 +0100
commit54c81ee9e87b1438dd2a95ff176335646d53e54f (patch)
tree0dcd5d0d1846d0df6bf1d690b36cbcaba1db379e /configure.ac
parentfa2f000a662907249e48798fc3b940ac9cac94f5 (diff)
Autotools build: Use pkg-config to find libexpat
The version of expat that added the .pc file was released in 2012. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=69801 Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 3882f3fc..5debaf6d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -933,17 +933,7 @@ fi
# unix:path=/foo or unix:abstract=/foo
AC_SUBST(DBUS_PATH_OR_ABSTRACT)
-#### Sort out XML library
-
-AC_CHECK_LIB(expat, XML_ParserCreate_MM,
- [ AC_CHECK_HEADERS(expat.h, [],
- [AC_MSG_ERROR([Could not find expat.h, check config.log for failed attempts])]) ],
- [ AC_MSG_ERROR([Explicitly requested expat but expat not found]) ])
-
-XML_LIBS=-lexpat
-XML_CFLAGS=
-AC_SUBST([XML_CFLAGS])
-AC_SUBST([XML_LIBS])
+PKG_CHECK_MODULES([EXPAT], [expat])
# Thread lib detection
AC_ARG_VAR([THREAD_LIBS])