summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Staudinger <robsta@gnome.org>2008-10-06 14:37:51 +0200
committerRobert Staudinger <robsta@gnome.org>2008-10-06 14:37:51 +0200
commitc9e311cbae2a9c3982a7672b3daa8232d4767de4 (patch)
tree6bb9fd2d2e05c2ef6d8aed0556b71b19934c3de9 /Makefile.am
Initial import.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..b8c42ac
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,31 @@
+
+ACLOCAL_AMFLAGS = -I .
+DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-werror
+
+SUBDIRS = ccss doc
+
+if CCSS_WITH_CLUTTER
+SUBDIRS += cccss
+endif
+
+if CCSS_WITH_GTK
+SUBDIRS += examples
+endif
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libccss-1.pc
+
+EXTRA_DIST = \
+ AUTHORS \
+ ChangeLog \
+ COPYING \
+ INSTALL \
+ NEWS \
+ README \
+ TODO \
+ autogen.sh \
+ libccss-1.pc.in
+
+distclean-local:
+ rm -rf *.cache *~
+