summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2018-08-16 16:55:09 +0800
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-22 09:01:14 +0200
commitfd654c40aea2d589f02ea8e89661cbe142bd72c6 (patch)
tree40180f51c5b5039fac4a51165cfb63901fb8dd86 /Makefile.am
parentad9b9e225527fc8951dadd3f1a2601d086b42ac2 (diff)
build: Add NMake Makefiles for MSVC builds
This adds a set of NMake Makefiles to build cairomm, and its example programs and its test programs (the test programs are not buildable in their current state). Visual Studio 2017 is still the minimum required version of Visual Studio required, with verion 15.8.0 or later recommended. The NMake Makefiles will consume cairomm/filelist.am, so that additions and removal of sources will only need to be done there, which will reduce the likelyhood of the MSVC build files getting out-of-date. Dist only the NMake Makefiles, and also dist the gendef, cairommconfig.h and cairomm.rc(.in) as we did before. The Visual Studio projects will be dropped in the next commit.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 33539ca..ff0de26 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,7 +33,7 @@ nodist_pkgconfig_DATA = $(CAIROMM_INSTALL_PC)
include $(srcdir)/MSVC_NMake/filelist.am
-msvc_files = $(addprefix MSVC_NMake/,$(msvc_net2017_data))
+msvc_files = $(addprefix MSVC_NMake/,$(msvc_nmake_data))
dist_noinst_DATA = MAINTAINERS $(msvc_files)
dist_noinst_SCRIPTS = autogen.sh