summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2015-09-10 15:37:35 +0800
committerMurray Cumming <murrayc@murrayc.com>2015-09-10 10:25:13 +0200
commitf3bf7977fed587038eb145dd8b9f0fdcef85f4c2 (patch)
tree359580d9e30984272d44c8fc871c41bb7158b03f /Makefile.am
parentb7ac2d8ee45571bdc7bee5b656c61dcb26084421 (diff)
MSVC Builds: Support Visual Studio 2013 (and later) Only
This removes the Visual Studio 2005 and 2008 projects, and updates the Visual Studio 2010 projects to become 2013 projects, as only Visual Studio 2013 and later support enough of C++-11 to build cairomm in its current state. Also update the README in MSVC_Net2013/ to reflect on this situation.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 3 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index a646fd9..33f8ec2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,18 +31,14 @@ nodist_cairomm_libinclude_HEADERS = cairommconfig.h
pkgconfigdir = $(libdir)/pkgconfig
nodist_pkgconfig_DATA = $(CAIROMM_INSTALL_PC)
-include $(srcdir)/MSVC_Net2005/filelist.am
-include $(srcdir)/MSVC_Net2008/filelist.am
-include $(srcdir)/MSVC_Net2010/filelist.am
+include $(srcdir)/MSVC_Net2013/filelist.am
-msvc_files = $(addprefix MSVC_Net2005/,$(msvc_net2005_data)) \
- $(addprefix MSVC_Net2008/,$(msvc_net2008_data)) \
- $(addprefix MSVC_Net2010/,$(msvc_net2010_data))
+msvc_files = $(addprefix MSVC_Net2013/,$(msvc_net2013_data))
dist_noinst_DATA = MAINTAINERS $(msvc_files)
dist_noinst_SCRIPTS = autogen.sh
-DISTCLEANFILES = MSVC_Net2005/cairomm/cairommconfig.h MSVC_Net2008/cairomm/cairommconfig.h MSVC_Net2010/cairomm/cairommconfig.h
+DISTCLEANFILES = MSVC_Net2013/cairomm/cairommconfig.h
# Optional: auto-generate the ChangeLog file from the git log on make dist
include $(top_srcdir)/build/dist-changelog.am