summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid King <davidk@openismus.com>2009-08-12 14:12:53 +0200
committerJonathon Jongsma <jjongsma@gnome.org>2009-08-13 11:08:51 -0500
commitde4e75a5e588ab8689bfe405391ff3c788c94018 (patch)
tree4648ad2ecb1db0da4087e398f1748fccc77b502a /Makefile.am
parent06de63b184325531c76270205c7392ff8c93466d (diff)
Switch to mm-common documentation build infrastructure
* .gitignore: Add new generated documentation files. * Makefile.am: Remove old documentation generation build. * configure.ac: * docs/reference/Makefile.am: Remove, with switch to non-recursive documentation build. * data/cairomm-1.0.pc.in: * docs/Makefile.am: Switch to new documentation build infrastructure from mm-common. * docs/reference/Doxyfile.in: Modernise and disable several unused features of the Doxygen output.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 2 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index c944872..51fb380 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,7 +18,7 @@ nodist_pkgconfig_DATA = data/$(CAIROMM_MODULE_NAME).pc
dist_noinst_SCRIPTS = autogen.sh
###
-EXTRA_DIST = MAINTAINERS autogen.sh
+EXTRA_DIST = MAINTAINERS
DIST_SUBDIRS = $(SUBDIRS)
@@ -123,14 +123,5 @@ release-publish: release-upload doc-publish releases/$(sha1_file)
@echo "Last but not least, do not forget to bump up the micro"
@echo "version component to the next (odd) number and commit."
-
-doc-clean-recursive:
- (cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-clean)
-
-doc-clean: doc-clean-recursive
-
-doc-rebuild:
- (cd docs && $(MAKE) $(AM_MAKEFLAGS) doc-rebuild)
-
-.PHONY: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky release-check release-upload release-publish doc-clean doc-clean-recursive doc-rebuild
+.PHONY: release-verify-even-micro release-verify-newer release-remove-old release-cleanup-group-sticky release-check release-upload release-publish