summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-23 14:59:30 +0200
committerKjell Ahlstedt <kjellahlstedt@gmail.com>2020-04-25 09:52:30 +0200
commitcb98a5313a4841a9da943b87f94beca5ca32578a (patch)
treeef6cab9768cd29bf9935d54fe99b9b547360fe43 /Makefile.am
parent715d9dd9b715cd3d367fe3a1fb3ce6c79941ecb8 (diff)
Add support for building cairomm with Meson
cairomm can be built with either Autotools or Meson. Fixes #20
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ff0de26..36c5240 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,20 @@ dist_noinst_SCRIPTS = autogen.sh
DISTCLEANFILES = MSVC_NMake/cairomm/cairommconfig.h
+# Distribute files needed when building cairomm with Meson.
+EXTRA_DIST = \
+ meson.build \
+ meson_options.txt \
+ cairommconfig.h.meson \
+ MSVC_NMake/cairomm/meson.build \
+ MSVC_NMake/gendef/meson.build \
+ data/meson.build \
+ docs/reference/meson.build \
+ cairomm/meson.build \
+ examples/meson.build \
+ tests/meson.build \
+ untracked/README
+
# Optional: auto-generate the ChangeLog file from the git log on make dist
include $(top_srcdir)/build/dist-changelog.am