summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2008-10-22 22:01:15 -0500
committerJonathon Jongsma <jjongsma@gnome.org>2008-10-22 22:01:15 -0500
commit6ba284d970f5e1efdd1c80065751b63c22e6ddac (patch)
tree45cadf4fa2382e92269ea3ac76ad20aa1ebad57c /Makefile.am
parentbbf5159397aac3f952d0c17a5e66e7fc40177b8b (diff)
move pkgconfig files to a data/ subdir
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am25
1 files changed, 2 insertions, 23 deletions
diff --git a/Makefile.am b/Makefile.am
index ace619f..7064426 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,34 +1,13 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = cairomm examples MSVC_Net2005 MSVC_Net2008 $(DOCS_SUBDIR) tests
+SUBDIRS = cairomm data examples MSVC_Net2005 MSVC_Net2008 $(DOCS_SUBDIR) tests
#docs examples
ACLOCAL_AMFLAGS = -I m4
-# This is a list of all of the possible pkg-config files that can be generated.
-# Specific ones to be installed are determined in configure.in
-ALL_PC_IN = cairomm-1.0.pc.in \
- cairomm-ft-1.0.pc.in \
- cairomm-pdf-1.0.pc.in \
- cairomm-png-1.0.pc.in \
- cairomm-ps-1.0.pc.in \
- cairomm-quartz-1.0.pc.in \
- cairomm-quartz-font-1.0.pc.in \
- cairomm-quartz-image-1.0.pc.in \
- cairomm-svg-1.0.pc.in \
- cairomm-win32-1.0.pc.in \
- cairomm-win32-font-1.0.pc.in \
- cairomm-xlib-1.0.pc.in \
- cairomm-xlib-xrender-1.0.pc.in
-
-EXTRA_DIST = MAINTAINERS $(ALL_PC_IN)
+EXTRA_DIST = MAINTAINERS
DIST_SUBDIRS = $(SUBDIRS)
-# Install the pkg-config files:
-pkgconfigdir = $(libdir)/pkgconfig
-# $INSTALLED_PC is computed in configure.in
-pkgconfig_DATA = cairomm-1.0.pc $(INSTALLED_PC)
-
# Copied from cairo/Makefile.am:
#
# Some custom targets to make it easier to release things.