summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJonathon Jongsma <jjongsma@gnome.org>2008-10-10 22:49:56 +0900
committerJonathon Jongsma <jjongsma@gnome.org>2008-10-10 22:49:56 +0900
commit4dfea66a05b8eb6c032797678ac98e51e913bb60 (patch)
tree2390176f940b9e64e9c7a15ec30ec3bc1d128d00 /Makefile.am
parente3ff8518c2b371cd27917ae195ef67a9ad3ea67b (diff)
Add a bunch of extra .pc files for additional functionality
This is done in a bit of a brute-force method at the moment. I have .pc.in templates for all possible files. Then I check the underlying cairo-XXX.pc files and if those exist, I generate the corresponding cairomm-XXX.pc file. It's not the prettiest solution, but it seems to work. So now, if you want to just use base cairo functionality, check for cairomm-1.0, but if you want to use other functionality that requires that you link your application against other libraries (e.g. freetype, xlib, etc), you should check for cairomm-ft-1.0, cairomm-xlib-1.0, etc.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 20 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6223f8c..5807200 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,13 +4,30 @@ SUBDIRS = cairomm examples MSVC_Net2005 $(DOCS_SUBDIR) tests
#docs examples
ACLOCAL_AMFLAGS = -I m4
-EXTRA_DIST = MAINTAINERS cairomm-1.0.pc.in
+# This is a list of all of the possible pkg-config files that can be generated.
+# Specific ones to be installed are determined in configure.in
+ALL_PC_IN = cairomm-1.0.pc.in \
+ cairomm-ft-1.0.pc.in \
+ cairomm-pdf-1.0.pc.in \
+ cairomm-png-1.0.pc.in \
+ cairomm-ps-1.0.pc.in \
+ cairomm-quartz-1.0.pc.in \
+ cairomm-quartz-font-1.0.pc.in \
+ cairomm-quartz-image-1.0.pc.in \
+ cairomm-svg-1.0.pc.in \
+ cairomm-win32-1.0.pc.in \
+ cairomm-win32-font-1.0.pc.in \
+ cairomm-xlib-1.0.pc.in \
+ cairomm-xlib-xrender-1.0.pc.in
+
+EXTRA_DIST = MAINTAINERS $(ALL_PC_IN)
DIST_SUBDIRS = $(SUBDIRS)
-# Install the pkg-config file:
+# Install the pkg-config files:
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = cairomm-1.0.pc
+# $INSTALLED_PC is computed in configure.in
+pkgconfig_DATA = cairomm-1.0.pc $(INSTALLED_PC)
# Copied from cairo/Makefile.am:
#