summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 2f80f9f89..e7fd3fd6b 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,17 +1,24 @@
# All new test cases go here
TESTS = \
fill_rule \
+leaky_polygon \
line_width \
-move_to_show_surface
+move_to_show_surface \
+text_cache_crash \
+text_rotate
# And all new test go here too. I really don't like having to repeat
# this list. Anyone know a good way to avoid it? Can I use a wildcard
# here?
EXTRA_DIST = \
fill_rule-ref.png \
+leaky_polygon-ref.png \
line_width-ref.png \
move_to_show_surface-ref.png
+# Once we can draw the text_rotate.c test case correctly, we should
+# create and add text_rotate-ref.png to the list of reference PNGs.
+
# This list is only for known bugs (not regressions). We do need to
# fix these before the next release, but they are expected to fail for
# now, so they don't need to hold up any new code commit.
@@ -20,8 +27,9 @@ move_to_show_surface-ref.png
# here. New failures due to local, uncommitted code changes are
# regression bugs that should not be listed here. Instead they should
# be fixed before the code is committed.
-XFAIL_TESTS = \
-move_to_show_surface
+XFAIL_TESTS = \
+move_to_show_surface \
+text_rotate
check_PROGRAMS = $(TESTS)
@@ -47,7 +55,10 @@ xmalloc.h
# time to break down and auto-generate the Makefile.am or something
# from autogen.sh. My, but this is painful...
fill_rule_SOURCES = fill_rule.c $(cairo_test_lib)
+leaky_polygon_SOURCES = leaky_polygon.c $(cairo_test_lib)
line_width_SOURCES = line_width.c $(cairo_test_lib)
move_to_show_surface_SOURCES = move_to_show_surface.c $(cairo_test_lib)
+text_cache_crash_SOURCES = text_cache_crash.c $(cairo_test_lib)
+text_rotate_SOURCES = text_rotate.c $(cairo_test_lib)
CLEANFILES = *-out.png *-diff.png