summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2008-09-20 17:20:36 -0400
committerBehdad Esfahbod <behdad@behdad.org>2008-09-20 17:20:36 -0400
commitfee72c26afff2120315ebbab32708520307e7a5e (patch)
treed9d09053fdaec65c3c54692a875490579460ef6f /src/Makefile.am
parente00565fa3c9579566abb31b71af3f13f44c45139 (diff)
Make sure feature macros are checked using #if, not #ifdef; add a test for it
This is more robust to cases where people want to assign 0 to those variables. (win32/alternate build systems, etc)
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9c434500e..4b6d86b56 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -70,10 +70,10 @@ TESTS_ENVIRONMENT = \
$(NULL)
TESTS_SH = \
check-def.sh \
- check-plt.sh \
- check-headers.sh \
- check-includes.sh \
check-doc-syntax.sh\
+ check-headers.sh \
+ check-plt.sh \
+ check-preprocessor-syntax.sh \
$(NULL)
TESTS += $(TESTS_SH)
if CROSS_COMPILING