summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2008-09-16 03:10:53 -0400
committerBehdad Esfahbod <behdad@behdad.org>2008-09-16 03:58:21 -0400
commit49c8c62040cdeb6b280392da9355593e1e8292fe (patch)
tree5e3118b66e979592ff2b59df74f37b68c516e9ed /src/Makefile.am
parenteb749d75632cfce6dfc56e6e28dac1cfcd8a66f9 (diff)
[src/Makefile.am.analysis] Split off from src/Makefile.am
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am21
1 files changed, 1 insertions, 20 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 88d40a5a1..60a552076 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -85,23 +85,4 @@ check_link_LDADD = libcairo.la
.c.i: $(cairoinclude_HEADERS) $(nodist_cairoinclude_HEADERS) cairoint.h $(top_builddir)/config.h
$(CPP) -DHAVE_CONFIG_H -I$(top_builddir) -I. $(AM_CPPFLAGS) $< -o $@
-SPARSE = sparse
-sparse:
- @status=true; for f in $(enabled_cairo_sources); do \
- echo sparse $$f; \
- $(SPARSE) -I$(top_builddir) $(AM_CPPFLAGS) -DHAVE_CONFIG_H $$f || status=false; \
- done; $$status
-
-SPLINT = splint -badflag
-splint:
- @status=true; for f in $(enabled_cairo_sources); do \
- test "$$f" = "`echo "$$f" | sed 's/[.]h$$//'`" || continue; \
- echo sparse $$f; \
- $(SPLINT) -I$(top_builddir) $(AM_CPPFLAGS) -DHAVE_CONFIG_H $$f || status=false; \
- done; $$status
-
-UNO = uno
-uno:
- @cpp_flags=`echo $(AM_CPPFLAGS) | sed 's/\(-I.*\) /\1 /g'`; \
- files=`echo $(enabled_cairo_sources) | sed 's/[^ ]*\.h//g'`; \
- $(UNO) -I$(top_builddir) $$cpp_flags -DHAVE_CONFIG_H -U__GNUC__ $$files
+include $(srcdir)/Makefile.am.analysis