summaryrefslogtreecommitdiff
path: root/src/devices/wifi/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/devices/wifi/meson.build')
-rw-r--r--src/devices/wifi/meson.build56
1 files changed, 56 insertions, 0 deletions
diff --git a/src/devices/wifi/meson.build b/src/devices/wifi/meson.build
new file mode 100644
index 0000000000..0b681262be
--- /dev/null
+++ b/src/devices/wifi/meson.build
@@ -0,0 +1,56 @@
+common_sources = files(
+ 'nm-wifi-ap.c',
+ 'nm-wifi-utils.c'
+)
+
+sources = common_sources + files(
+ 'nm-wifi-factory.c',
+ 'nm-device-wifi.c',
+ 'nm-device-olpc-mesh.c'
+)
+
+if enable_iwd
+ sources += files(
+ 'nm-device-iwd.c',
+ 'nm-iwd-manager.c',
+ )
+endif
+
+deps = [
+ core_dep,
+ libnmdbus_dep
+]
+
+ldflags = []
+if have_version_script
+ ldflags += '-Wl,--version-script,@0@'.format(linker_script_devices)
+endif
+
+libnm_device_plugin_wifi = shared_module(
+ 'nm-device-plugin-wifi',
+ sources: sources,
+ dependencies: deps,
+ link_args: ldflags,
+ link_depends: linker_script_devices,
+ install: true,
+ install_dir: nm_pkglibdir
+)
+
+core_plugins += libnm_device_plugin_wifi
+
+run_target(
+ 'check-local-devices-wifi',
+ command: [check_exports, libnm_device_plugin_wifi.full_path(), linker_script_devices],
+ depends: libnm_device_plugin_wifi
+)
+
+# FIXME: check_so_symbols replacement
+'''
+check-local-devices-wifi: src/devices/wifi/libnm-device-plugin-wifi.la
+ $(srcdir)/tools/check-exports.sh $(builddir)/src/devices/wifi/.libs/libnm-device-plugin-wifi.so "$(srcdir)/linker-script-devices.ver"
+ $(call check_so_symbols,$(builddir)/src/devices/wifi/.libs/libnm-device-plugin-wifi.so)
+'''
+
+if enable_tests
+ subdir('tests')
+endif