summaryrefslogtreecommitdiff
path: root/libnm-glib/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libnm-glib/tests/Makefile.am')
-rw-r--r--libnm-glib/tests/Makefile.am47
1 files changed, 0 insertions, 47 deletions
diff --git a/libnm-glib/tests/Makefile.am b/libnm-glib/tests/Makefile.am
deleted file mode 100644
index 09f34d1847..0000000000
--- a/libnm-glib/tests/Makefile.am
+++ /dev/null
@@ -1,47 +0,0 @@
-if ENABLE_TESTS
-
-AM_CPPFLAGS = \
- -I$(top_srcdir)/shared \
- -I$(top_builddir)/shared \
- -I$(top_srcdir)/libnm-util \
- -I$(top_builddir)/libnm-util \
- -I$(top_srcdir)/libnm-glib \
- -DNETWORKMANAGER_COMPILATION=NM_NETWORKMANAGER_COMPILATION_LIB_LEGACY \
- -DTEST_NM_SERVICE=\"$(abs_top_srcdir)/tools/test-networkmanager-service.py\" \
- $(GLIB_CFLAGS) \
- $(DBUS_CFLAGS)
-
-noinst_PROGRAMS = $(TESTS)
-
-@NM_LOG_COMPILER@
-TESTS = test-nm-client test-remote-settings-client
-
-####### NMClient and non-settings tests #######
-
-test_nm_client_SOURCES = \
- $(top_builddir)/shared/nm-test-utils-impl.c \
- $(top_builddir)/shared/nm-test-libnm-utils.h \
- test-nm-client.c
-
-test_nm_client_LDADD = \
- $(top_builddir)/libnm-util/libnm-util.la \
- $(top_builddir)/libnm-glib/libnm-glib.la \
- $(GLIB_LIBS) \
- $(DBUS_LIBS)
-
-####### remote settings client test #######
-
-test_remote_settings_client_SOURCES = \
- $(top_builddir)/shared/nm-test-utils-impl.c \
- $(top_builddir)/shared/nm-test-libnm-utils.h \
- test-remote-settings-client.c
-
-test_remote_settings_client_LDADD = \
- $(top_builddir)/libnm-util/libnm-util.la \
- $(top_builddir)/libnm-glib/libnm-glib.la \
- $(GLIB_LIBS) \
- $(DBUS_LIBS)
-
-###########################################
-
-endif