summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2019-05-28 13:08:32 +0200
committerThomas Haller <thaller@redhat.com>2019-05-29 09:42:40 +0200
commita307bd6ec4c1724324d0a2fbb09ebfe46a996d13 (patch)
tree5b753e7def128e387875fc3ddf22b44a6223445b /meson.build
parent7af1fc803e98a8201a9c79cf11494de13151527f (diff)
build: disable "-Wunknown-pragmas" warning
clang on CentOS 7.6 (3.4.2-9.el7) warns: CC clients/tui/newt/clients_tui_newt_libnmt_newt_a-nmt-newt-button.o In file included from ../clients/tui/newt/nmt-newt-button.c:26: In file included from ../shared/nm-default.h:280: ../shared/nm-glib-aux/nm-macros-internal.h:1617:2: error: unknown warning group -Wstringop-truncation, ignored [-Werror,-Wunknown-pragmas] NM_PRAGMA_WARNING_DISABLE ("-Wstringop-truncation"); ^ ../shared/nm-glib-aux/nm-macros-internal.h:419:9: note: expanded from macro NM_PRAGMA_WARNING_DISABLE _Pragma(_NM_PRAGMA_WARNING_DO(warning)) ^ <scratch space>:109:25: note: expanded from here GCC diagnostic ignored "-Wstringop-truncation" ^ This warning totally defeats the purpose of why we use the pragma in the first place.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e6b220c62b..af4faa4bc6 100644
--- a/meson.build
+++ b/meson.build
@@ -152,6 +152,7 @@ if nm_debug
'-Wno-missing-field-initializers',
'-Wno-pragmas',
'-Wno-sign-compare',
+ '-Wno-unknown-pragmas',
'-Wno-unused-parameter',
'-Wparentheses-equality',
'-Wpointer-arith',