summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThomas Haller <thaller@redhat.com>2018-02-16 13:01:12 +0100
committerThomas Haller <thaller@redhat.com>2018-02-16 13:26:07 +0100
commit997cce7c90bf059f93fa9391bad591c56688e4ac (patch)
treebf3fb97e99c8eb6a60613b21fbeede413deae387 /meson.build
parent5f1c1be4624fd5b167592f72b82beae1a9c38a3d (diff)
build: fix glib dependency to require at least 2.40
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build11
1 files changed, 3 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 4b09a84cc1..7b902486a2 100644
--- a/meson.build
+++ b/meson.build
@@ -209,23 +209,18 @@ config_h.set10('HAVE_LIBSYSTEMD', libsystemd_dep.found())
systemd_dep = dependency('systemd', required: false)
have_systemd_200 = systemd_dep.found() and systemd_dep.version().version_compare('>= 200')
-gio_unix_dep = dependency('gio-unix-2.0', version: '>= 2.32')
+gio_unix_dep = dependency('gio-unix-2.0', version: '>= 2.40')
log_driver = join_paths(meson.source_root(), 'build-aux', (gio_unix_dep.version().version_compare('>= 2.37.6') ? 'tap-driver.sh' : 'test-driver'))
-# FIXME: same version? which version?
-# GLIB_VERSION_MIN_REQUIRED should match the version above.
-# GLIB_VERSION_MAX_ALLOWED should be set to the same version;
-# nm-glib.h will cause it to be overridden for the functions
-# we have compat versions of.
glib_dep = declare_dependency(
dependencies: [
gio_unix_dep,
dependency('gmodule-2.0')
],
compile_args: [
- '-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_32',
- '-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_32'
+ '-DGLIB_VERSION_MIN_REQUIRED=GLIB_VERSION_2_40',
+ '-DGLIB_VERSION_MAX_ALLOWED=GLIB_VERSION_2_40'
]
)